p PatchFirst

CVE-2026-25958

CVE-2026-25958 · Cube privilege escalation via a specially crafted request

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Cube is a semantic layer for building data applications. From 0.27.19 to before 1.5.13, 1.4.2, and 1.0.14, it is possible to make a specially crafted request with a valid API token that leads to privilege escalation. This vulnerability is fixed in 1.5.13, 1.4.2, and 1.0.14.

CVSS 7.7 · Élevée · EPSS 0,4% · Correctif disponible

Publication
Mise à jour

Pile logicielle: node

Produits et versions concernés

  • cube

    Versions du logiciel
    • >= 0.27.19, < 1.0.14: Concernée
    • >= 1.1.0, < 1.4.2: Concernée
    • >= 1.5.0, < 1.5.13: Concernée

    Aucun correctif publié

  • @cubejs-backend/server-core npm

    Plages de versions concernées
    • SEMVER: ≥ 0.27.19, < 1.0.14

    Mettez à jour vers 1.0.14

  • @cubejs-backend/server-core npm

    Plages de versions concernées
    • SEMVER: ≥ 1.1.0, < 1.4.2

    Mettez à jour vers 1.4.2

  • @cubejs-backend/server-core npm

    Plages de versions concernées
    • SEMVER: ≥ 1.5.0, < 1.5.13

    Mettez à jour vers 1.5.13

Sources originales

Vérifiez votre serveur →