CVE-2026-25958
CVE-2026-25958 · Cube privilege escalation via a specially crafted request
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Cube is a semantic layer for building data applications. From 0.27.19 to before 1.5.13, 1.4.2, and 1.0.14, it is possible to make a specially crafted request with a valid API token that leads to privilege escalation. This vulnerability is fixed in 1.5.13, 1.4.2, and 1.0.14.
CVSS 7.7 · High · EPSS 0.4% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
cube
- Versions
- >= 0.27.19, < 1.0.14: Affected
- >= 1.1.0, < 1.4.2: Affected
- >= 1.5.0, < 1.5.13: Affected
No fix published
@cubejs-backend/server-core npm
- Affected ranges
- SEMVER: ≥ 0.27.19, < 1.0.14
Update to 1.0.14
@cubejs-backend/server-core npm
- Affected ranges
- SEMVER: ≥ 1.1.0, < 1.4.2
Update to 1.4.2
@cubejs-backend/server-core npm
- Affected ranges
- SEMVER: ≥ 1.5.0, < 1.5.13
Update to 1.5.13