p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de lodash-rails

Vulnérabilité publiée pour lodash-rails au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 7

  1. CVE-2019-10744

    Critique · CVSS 9.1EPSS 5,01%Correctif disponible

    CVE-2019-10744

    Versions of lodash lower than 4.17.12 are vulnerable to Prototype Pollution. The function defaultsDeep could be tricked into adding or modifying properties of Object.prototype using a constructor payload.

    • Mettez à jour vers 4.17.12
    Publication Mise à jour
  2. CVE-2019-1010266

    Moyenne · CVSS 6.5EPSS 3,04%Correctif disponible

    CVE-2019-1010266

    lodash prior to 4.17.11 is affected by: CWE-400: Uncontrolled Resource Consumption. The impact is: Denial of service. The component is: Date handler. The attack vector is: Attacker provides very long strings, which the library attempts to match using a regular expression. The fixed version is: 4.17.11.

    • Mettez à jour vers 4.17.11
    Publication Mise à jour
  3. CVE-2018-16487

    Moyenne · CVSS 5.6EPSS 1,49%Correctif disponible

    CVE-2018-16487

    A prototype pollution vulnerability was found in lodash <4.17.11 where the functions merge, mergeWith, and defaultsDeep can be tricked into adding or modifying properties of Object.prototype.

    • Mettez à jour vers 4.17.11
    Publication Mise à jour
  4. CVE-2018-3721

    Moyenne · CVSS 6.5EPSS 2,35%Correctif disponible

    CVE-2018-3721

    lodash node module before 4.17.5 suffers from a Modification of Assumed-Immutable Data (MAID) vulnerability via defaultsDeep, merge, and mergeWith functions, which allows a malicious user to modify the prototype of "Object" via __proto__, causing the addition or modification of an existing property that will exist on all objects.

    • Mettez à jour vers 4.17.5
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →