ALPINE-CVE-2020-35452
ALPINE-CVE-2020-35452
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Apache HTTP Server versions 2.4.0 to 2.4.46 A specially crafted Digest nonce can cause a stack overflow in mod_auth_digest. There is no report of this overflow being exploitable, nor the Apache HTTP Server team could create one, though some particular compiler and/or compilation option might make it possible, with limited consequences anyway due to the size (a single byte) and the value (zero byte) of the overflow
CVSS 7.3 · High · Fix available
- Published
- Updated
Stack: system
Affected products and versions
apache2 Alpine:v3.10
- Affected ranges
- ECOSYSTEM: < 2.4.48-r0
Update to 2.4.48-r0
apache2 Alpine:v3.11
- Affected ranges
- ECOSYSTEM: < 2.4.48-r0
Update to 2.4.48-r0
apache2 Alpine:v3.12
- Affected ranges
- ECOSYSTEM: < 2.4.48-r0
Update to 2.4.48-r0
apache2 Alpine:v3.13
- Affected ranges
- ECOSYSTEM: < 2.4.48-r0
Update to 2.4.48-r0
apache2 Alpine:v3.14
- Affected ranges
- ECOSYSTEM: < 2.4.48-r0
Update to 2.4.48-r0
apache2 Alpine:v3.15
- Affected ranges
- ECOSYSTEM: < 2.4.48-r0
Update to 2.4.48-r0
apache2 Alpine:v3.16
- Affected ranges
- ECOSYSTEM: < 2.4.48-r0
Update to 2.4.48-r0
apache2 Alpine:v3.17
- Affected ranges
- ECOSYSTEM: < 2.4.48-r0
Update to 2.4.48-r0
apache2 Alpine:v3.18
- Affected ranges
- ECOSYSTEM: < 2.4.48-r0
Update to 2.4.48-r0
apache2 Alpine:v3.19
- Affected ranges
- ECOSYSTEM: < 2.4.48-r0
Update to 2.4.48-r0
apache2 Alpine:v3.20
- Affected ranges
- ECOSYSTEM: < 2.4.48-r0
Update to 2.4.48-r0
apache2 Alpine:v3.21
- Affected ranges
- ECOSYSTEM: < 2.4.48-r0
Update to 2.4.48-r0
apache2 Alpine:v3.22
- Affected ranges
- ECOSYSTEM: < 2.4.48-r0
Update to 2.4.48-r0
apache2 Alpine:v3.23
- Affected ranges
- ECOSYSTEM: < 2.4.48-r0
Update to 2.4.48-r0
apache2 Alpine:v3.24
- Affected ranges
- ECOSYSTEM: < 2.4.48-r0
Update to 2.4.48-r0