ALPINE-CVE-2021-39275
ALPINE-CVE-2021-39275
This page contains facts from public vulnerability sources. Check the original advisory before updating.
ap_escape_quotes() may write beyond the end of a buffer when given malicious input. No included modules pass untrusted data to these functions, but third-party / external modules may. This issue affects Apache HTTP Server 2.4.48 and earlier.
CVSS 9.8 · Critical · Fix available
- Published
- Updated
Stack: system
Affected products and versions
apache2 Alpine:v3.11
- Affected ranges
- ECOSYSTEM: < 2.4.49-r0
Update to 2.4.49-r0
apache2 Alpine:v3.12
- Affected ranges
- ECOSYSTEM: < 2.4.49-r0
Update to 2.4.49-r0
apache2 Alpine:v3.13
- Affected ranges
- ECOSYSTEM: < 2.4.49-r0
Update to 2.4.49-r0
apache2 Alpine:v3.14
- Affected ranges
- ECOSYSTEM: < 2.4.49-r0
Update to 2.4.49-r0
apache2 Alpine:v3.15
- Affected ranges
- ECOSYSTEM: < 2.4.49-r0
Update to 2.4.49-r0
apache2 Alpine:v3.16
- Affected ranges
- ECOSYSTEM: < 2.4.49-r0
Update to 2.4.49-r0
apache2 Alpine:v3.17
- Affected ranges
- ECOSYSTEM: < 2.4.49-r0
Update to 2.4.49-r0
apache2 Alpine:v3.18
- Affected ranges
- ECOSYSTEM: < 2.4.49-r0
Update to 2.4.49-r0
apache2 Alpine:v3.19
- Affected ranges
- ECOSYSTEM: < 2.4.49-r0
Update to 2.4.49-r0
apache2 Alpine:v3.20
- Affected ranges
- ECOSYSTEM: < 2.4.49-r0
Update to 2.4.49-r0
apache2 Alpine:v3.21
- Affected ranges
- ECOSYSTEM: < 2.4.49-r0
Update to 2.4.49-r0
apache2 Alpine:v3.22
- Affected ranges
- ECOSYSTEM: < 2.4.49-r0
Update to 2.4.49-r0
apache2 Alpine:v3.23
- Affected ranges
- ECOSYSTEM: < 2.4.49-r0
Update to 2.4.49-r0
apache2 Alpine:v3.24
- Affected ranges
- ECOSYSTEM: < 2.4.49-r0
Update to 2.4.49-r0