ALPINE-CVE-2021-40438
ALPINE-CVE-2021-40438
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A crafted request uri-path can cause mod_proxy to forward the request to an origin server choosen by the remote user. This issue affects Apache HTTP Server 2.4.48 and earlier.
CVSS 9.0 · Critical · Fix available
- Published
- Updated
Stack: system
Affected products and versions
apache2 Alpine:v3.11
- Affected ranges
- ECOSYSTEM: < 2.4.49-r0
Update to 2.4.49-r0
apache2 Alpine:v3.12
- Affected ranges
- ECOSYSTEM: < 2.4.49-r0
Update to 2.4.49-r0
apache2 Alpine:v3.13
- Affected ranges
- ECOSYSTEM: < 2.4.49-r0
Update to 2.4.49-r0
apache2 Alpine:v3.14
- Affected ranges
- ECOSYSTEM: < 2.4.49-r0
Update to 2.4.49-r0
apache2 Alpine:v3.15
- Affected ranges
- ECOSYSTEM: < 2.4.49-r0
Update to 2.4.49-r0
apache2 Alpine:v3.16
- Affected ranges
- ECOSYSTEM: < 2.4.49-r0
Update to 2.4.49-r0
apache2 Alpine:v3.17
- Affected ranges
- ECOSYSTEM: < 2.4.49-r0
Update to 2.4.49-r0
apache2 Alpine:v3.18
- Affected ranges
- ECOSYSTEM: < 2.4.49-r0
Update to 2.4.49-r0
apache2 Alpine:v3.19
- Affected ranges
- ECOSYSTEM: < 2.4.49-r0
Update to 2.4.49-r0
apache2 Alpine:v3.20
- Affected ranges
- ECOSYSTEM: < 2.4.49-r0
Update to 2.4.49-r0
apache2 Alpine:v3.21
- Affected ranges
- ECOSYSTEM: < 2.4.49-r0
Update to 2.4.49-r0
apache2 Alpine:v3.22
- Affected ranges
- ECOSYSTEM: < 2.4.49-r0
Update to 2.4.49-r0
apache2 Alpine:v3.23
- Affected ranges
- ECOSYSTEM: < 2.4.49-r0
Update to 2.4.49-r0
apache2 Alpine:v3.24
- Affected ranges
- ECOSYSTEM: < 2.4.49-r0
Update to 2.4.49-r0