ALPINE-CVE-2021-42013
ALPINE-CVE-2021-42013
This page contains facts from public vulnerability sources. Check the original advisory before updating.
It was found that the fix for CVE-2021-41773 in Apache HTTP Server 2.4.50 was insufficient. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue only affects Apache 2.4.49 and Apache 2.4.50 and not earlier versions.
CVSS 9.8 · Critical · Fix available
- Published
- Updated
Stack: system
Affected products and versions
apache2 Alpine:v3.11
- Affected ranges
- ECOSYSTEM: < 2.4.51-r0
Update to 2.4.51-r0
apache2 Alpine:v3.12
- Affected ranges
- ECOSYSTEM: < 2.4.51-r0
Update to 2.4.51-r0
apache2 Alpine:v3.13
- Affected ranges
- ECOSYSTEM: < 2.4.51-r0
Update to 2.4.51-r0
apache2 Alpine:v3.14
- Affected ranges
- ECOSYSTEM: < 2.4.51-r0
Update to 2.4.51-r0
apache2 Alpine:v3.15
- Affected ranges
- ECOSYSTEM: < 2.4.51-r0
Update to 2.4.51-r0
apache2 Alpine:v3.16
- Affected ranges
- ECOSYSTEM: < 2.4.51-r0
Update to 2.4.51-r0
apache2 Alpine:v3.17
- Affected ranges
- ECOSYSTEM: < 2.4.51-r0
Update to 2.4.51-r0
apache2 Alpine:v3.18
- Affected ranges
- ECOSYSTEM: < 2.4.51-r0
Update to 2.4.51-r0
apache2 Alpine:v3.19
- Affected ranges
- ECOSYSTEM: < 2.4.51-r0
Update to 2.4.51-r0
apache2 Alpine:v3.20
- Affected ranges
- ECOSYSTEM: < 2.4.51-r0
Update to 2.4.51-r0
apache2 Alpine:v3.21
- Affected ranges
- ECOSYSTEM: < 2.4.51-r0
Update to 2.4.51-r0
apache2 Alpine:v3.22
- Affected ranges
- ECOSYSTEM: < 2.4.51-r0
Update to 2.4.51-r0
apache2 Alpine:v3.23
- Affected ranges
- ECOSYSTEM: < 2.4.51-r0
Update to 2.4.51-r0
apache2 Alpine:v3.24
- Affected ranges
- ECOSYSTEM: < 2.4.51-r0
Update to 2.4.51-r0