ALPINE-CVE-2021-44790
ALPINE-CVE-2021-44790
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A carefully crafted request body can cause a buffer overflow in the mod_lua multipart parser (r:parsebody() called from Lua scripts). The Apache httpd team is not aware of an exploit for the vulnerabilty though it might be possible to craft one. This issue affects Apache HTTP Server 2.4.51 and earlier.
CVSS 9.8 · Critical · Fix available
- Published
- Updated
Stack: system
Affected products and versions
apache2 Alpine:v3.12
- Affected ranges
- ECOSYSTEM: < 2.4.52-r0
Update to 2.4.52-r0
apache2 Alpine:v3.13
- Affected ranges
- ECOSYSTEM: < 2.4.52-r0
Update to 2.4.52-r0
apache2 Alpine:v3.14
- Affected ranges
- ECOSYSTEM: < 2.4.52-r0
Update to 2.4.52-r0
apache2 Alpine:v3.15
- Affected ranges
- ECOSYSTEM: < 2.4.52-r0
Update to 2.4.52-r0
apache2 Alpine:v3.16
- Affected ranges
- ECOSYSTEM: < 2.4.52-r0
Update to 2.4.52-r0
apache2 Alpine:v3.17
- Affected ranges
- ECOSYSTEM: < 2.4.52-r0
Update to 2.4.52-r0
apache2 Alpine:v3.18
- Affected ranges
- ECOSYSTEM: < 2.4.52-r0
Update to 2.4.52-r0
apache2 Alpine:v3.19
- Affected ranges
- ECOSYSTEM: < 2.4.52-r0
Update to 2.4.52-r0
apache2 Alpine:v3.20
- Affected ranges
- ECOSYSTEM: < 2.4.52-r0
Update to 2.4.52-r0
apache2 Alpine:v3.21
- Affected ranges
- ECOSYSTEM: < 2.4.52-r0
Update to 2.4.52-r0
apache2 Alpine:v3.22
- Affected ranges
- ECOSYSTEM: < 2.4.52-r0
Update to 2.4.52-r0
apache2 Alpine:v3.23
- Affected ranges
- ECOSYSTEM: < 2.4.52-r0
Update to 2.4.52-r0
apache2 Alpine:v3.24
- Affected ranges
- ECOSYSTEM: < 2.4.52-r0
Update to 2.4.52-r0