ALPINE-CVE-2022-28614
ALPINE-CVE-2022-28614
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The ap_rwrite() function in Apache HTTP Server 2.4.53 and earlier may read unintended memory if an attacker can cause the server to reflect very large input using ap_rwrite() or ap_rputs(), such as with mod_luas r:puts() function. Modules compiled and distributed separately from Apache HTTP Server that use the 'ap_rputs' function and may pass it a very large (INT_MAX or larger) string must be compiled against current headers to resolve the issue.
CVSS 5.3 · Medium · Fix available
- Published
- Updated
Stack: system
Affected products and versions
apache2 Alpine:v3.13
- Affected ranges
- ECOSYSTEM: < 2.4.54-r0
Update to 2.4.54-r0
apache2 Alpine:v3.14
- Affected ranges
- ECOSYSTEM: < 2.4.54-r0
Update to 2.4.54-r0
apache2 Alpine:v3.15
- Affected ranges
- ECOSYSTEM: < 2.4.54-r0
Update to 2.4.54-r0
apache2 Alpine:v3.16
- Affected ranges
- ECOSYSTEM: < 2.4.54-r0
Update to 2.4.54-r0
apache2 Alpine:v3.17
- Affected ranges
- ECOSYSTEM: < 2.4.54-r0
Update to 2.4.54-r0
apache2 Alpine:v3.18
- Affected ranges
- ECOSYSTEM: < 2.4.54-r0
Update to 2.4.54-r0
apache2 Alpine:v3.19
- Affected ranges
- ECOSYSTEM: < 2.4.54-r0
Update to 2.4.54-r0
apache2 Alpine:v3.20
- Affected ranges
- ECOSYSTEM: < 2.4.54-r0
Update to 2.4.54-r0
apache2 Alpine:v3.21
- Affected ranges
- ECOSYSTEM: < 2.4.54-r0
Update to 2.4.54-r0
apache2 Alpine:v3.22
- Affected ranges
- ECOSYSTEM: < 2.4.54-r0
Update to 2.4.54-r0
apache2 Alpine:v3.23
- Affected ranges
- ECOSYSTEM: < 2.4.54-r0
Update to 2.4.54-r0
apache2 Alpine:v3.24
- Affected ranges
- ECOSYSTEM: < 2.4.54-r0
Update to 2.4.54-r0