ALPINE-CVE-2022-41556
ALPINE-CVE-2022-41556
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A resource leak in gw_backend.c in lighttpd 1.4.56 through 1.4.66 could lead to a denial of service (connection-slot exhaustion) after a large amount of anomalous TCP behavior by clients. It is related to RDHUP mishandling in certain HTTP/1.1 chunked situations. Use of mod_fastcgi is, for example, affected. This is fixed in 1.4.67.
CVSS 7.5 · High · Fix available
- Published
- Updated
Stack: system
Affected products and versions
lighttpd Alpine:v3.15
- Affected ranges
- ECOSYSTEM: ≥ 1.4.56, < 1.4.67-r0
Update to 1.4.67-r0
lighttpd Alpine:v3.16
- Affected ranges
- ECOSYSTEM: ≥ 1.4.56, < 1.4.67-r0
Update to 1.4.67-r0
lighttpd Alpine:v3.17
- Affected ranges
- ECOSYSTEM: ≥ 1.4.56, < 1.4.67-r0
Update to 1.4.67-r0
lighttpd Alpine:v3.18
- Affected ranges
- ECOSYSTEM: ≥ 1.4.56, < 1.4.67-r0
Update to 1.4.67-r0
lighttpd Alpine:v3.19
- Affected ranges
- ECOSYSTEM: ≥ 1.4.56, < 1.4.67-r0
Update to 1.4.67-r0
lighttpd Alpine:v3.20
- Affected ranges
- ECOSYSTEM: ≥ 1.4.56, < 1.4.67-r0
Update to 1.4.67-r0
lighttpd Alpine:v3.21
- Affected ranges
- ECOSYSTEM: ≥ 1.4.56, < 1.4.67-r0
Update to 1.4.67-r0
lighttpd Alpine:v3.22
- Affected ranges
- ECOSYSTEM: ≥ 1.4.56, < 1.4.67-r0
Update to 1.4.67-r0
lighttpd Alpine:v3.23
- Affected ranges
- ECOSYSTEM: ≥ 1.4.56, < 1.4.67-r0
Update to 1.4.67-r0
lighttpd Alpine:v3.24
- Affected ranges
- ECOSYSTEM: ≥ 1.4.56, < 1.4.67-r0
Update to 1.4.67-r0