ALPINE-CVE-2025-49812
ALPINE-CVE-2025-49812
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In some mod_ssl configurations on Apache HTTP Server versions through to 2.4.63, an HTTP desynchronisation attack allows a man-in-the-middle attacker to hijack an HTTP session via a TLS upgrade. Only configurations using "SSLEngine optional" to enable TLS upgrades are affected. Users are recommended to upgrade to version 2.4.64, which removes support for TLS upgrade.
CVSS 7.4 · High · Fix available
- Published
- Updated
Stack: system
Affected products and versions
apache2 Alpine:v3.19
- Affected ranges
- ECOSYSTEM: < 2.4.64-r0
Update to 2.4.64-r0
apache2 Alpine:v3.20
- Affected ranges
- ECOSYSTEM: < 2.4.64-r0
Update to 2.4.64-r0
apache2 Alpine:v3.21
- Affected ranges
- ECOSYSTEM: < 2.4.64-r0
Update to 2.4.64-r0
apache2 Alpine:v3.22
- Affected ranges
- ECOSYSTEM: < 2.4.64-r0
Update to 2.4.64-r0
apache2 Alpine:v3.23
- Affected ranges
- ECOSYSTEM: < 2.4.64-r0
Update to 2.4.64-r0
apache2 Alpine:v3.24
- Affected ranges
- ECOSYSTEM: < 2.4.64-r0
Update to 2.4.64-r0