p PatchFirst

ALPINE-CVE-2026-7210

ALPINE-CVE-2026-7210

This page contains facts from public vulnerability sources. Check the original advisory before updating.

`xml.parsers.expat` and `xml.etree.ElementTree` use insufficient entropy for Expat hash-flooding protection, which allows a crafted XML document to trigger hash flooding.\r\n\r\nFully mitigating this vulnerability requires both updating libexpat to 2.8.0 or later and applying this patch.

CVSS 7.5 · High · Fix available

Published
Updated

Stack: system

Affected products and versions

  • python3 Alpine:v3.21

    Affected ranges
    • ECOSYSTEM: < 3.12.14-r0

    Update to 3.12.14-r0

  • python3 Alpine:v3.22

    Affected ranges
    • ECOSYSTEM: < 3.12.14-r0

    Update to 3.12.14-r0

  • python3 Alpine:v3.23

    Affected ranges
    • ECOSYSTEM: < 3.12.14-r0

    Update to 3.12.14-r0

  • python3 Alpine:v3.24

    Affected ranges
    • ECOSYSTEM: < 3.14.7-r0

    Update to 3.14.7-r0

Original sources

Check your server →