p PatchFirst

PatchFirst · Latest vulnerabilities

apache2 vulnerabilities

Vulnerabilities published for apache2 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 36

  1. ALPINE-CVE-2020-9490

    High · CVSS 7.5Fix available

    ALPINE-CVE-2020-9490

    Apache HTTP Server versions 2.4.20 to 2.4.43. A specially crafted value for the 'Cache-Digest' header in a HTTP/2 request would result in a crash when the server actually tries to HTTP/2 PUSH a resource afterwards. Configuring the HTTP/2 feature via "H2Push off" will mitigate this vulnerability for unpatched servers.

    • Update to 2.4.46-r0
    Published Updated
  2. ALPINE-CVE-2020-11993

    High · CVSS 7.5Fix available

    ALPINE-CVE-2020-11993

    Apache HTTP Server versions 2.4.20 to 2.4.43 When trace/debug was enabled for the HTTP/2 module and on certain traffic edge patterns, logging statements were made on the wrong connection, causing concurrent use of memory pools. Configuring the LogLevel of mod_http2 above "info" will mitigate this vulnerability for unpatched servers.

    • Update to 2.4.46-r0
    Published Updated
  3. ALPINE-CVE-2019-10097

    High · CVSS 7.2Fix available

    ALPINE-CVE-2019-10097

    In Apache HTTP Server 2.4.32-2.4.39, when mod_remoteip was configured to use a trusted intermediary proxy server using the "PROXY" protocol, a specially crafted PROXY header could trigger a stack buffer overflow or NULL pointer deference. This vulnerability could only be triggered by a trusted proxy and not by untrusted HTTP clients.

    • Update to 2.4.41-r0
    Published Updated
  4. ALPINE-CVE-2019-10092

    Medium · CVSS 6.1Fix available

    ALPINE-CVE-2019-10092

    In Apache HTTP Server 2.4.0-2.4.39, a limited cross-site scripting issue was reported affecting the mod_proxy error page. An attacker could cause the link on the error page to be malformed and instead point to a page of their choice. This would only be exploitable where a server was set up with proxying enabled but was misconfigured in such a way that the Proxy Error page was displayed.

    • Update to 2.4.41-r0
    Published Updated
  5. ALPINE-CVE-2019-10081

    High · CVSS 7.5Fix available

    ALPINE-CVE-2019-10081

    HTTP/2 (2.4.20 through 2.4.39) very early pushes, for example configured with "H2PushResource", could lead to an overwrite of memory in the pushing request's pool, leading to crashes. The memory copied is that of the configured push link header values, not data supplied by the client.

    • Update to 2.4.41-r0
    Published Updated
  6. ALPINE-CVE-2019-9517

    High · CVSS 7.5Fix available

    ALPINE-CVE-2019-9517

    Some HTTP/2 implementations are vulnerable to unconstrained interal data buffering, potentially leading to a denial of service. The attacker opens the HTTP/2 window so the peer can send without constraint; however, they leave the TCP window closed so the peer cannot actually write (many of) the bytes on the wire. The attacker then sends a stream of requests for a large response object. Depending on how the servers queue the responses, this can consume excess memory, CPU, or both.

    • Update to 2.4.41-r0
    Published Updated
  7. ALPINE-CVE-2019-0197

    Medium · CVSS 4.2Fix available

    ALPINE-CVE-2019-0197

    A vulnerability was found in Apache HTTP Server 2.4.34 to 2.4.38. When HTTP/2 was enabled for a http: host or H2Upgrade was enabled for h2 on a https: host, an Upgrade request from http/1.1 to http/2 that was not the first request on a connection could lead to a misconfiguration and crash. Server that never enabled the h2 protocol or that only enabled it for https: and did not set "H2Upgrade on" are unaffected by this issue.

    • Update to 2.4.39-r0
    Published Updated
  8. ALPINE-CVE-2019-0196

    Medium · CVSS 5.3Fix available

    ALPINE-CVE-2019-0196

    A vulnerability was found in Apache HTTP Server 2.4.17 to 2.4.38. Using fuzzed network input, the http/2 request handling could be made to access freed memory in string comparison when determining the method of a request and thus process the request incorrectly.

    • Update to 2.4.39-r0
    Published Updated
  9. ALPINE-CVE-2019-0220

    Medium · CVSS 5.3Fix available

    ALPINE-CVE-2019-0220

    A vulnerability was found in Apache HTTP Server 2.4.0 to 2.4.38. When the path component of a request URL contains multiple consecutive slashes ('/'), directives such as LocationMatch and RewriteRule must account for duplicates in regular expressions while other aspects of the servers processing will implicitly collapse them.

    • Update to 2.4.39-r0
    Published Updated
  10. ALPINE-CVE-2019-0211

    High · CVSS 7.8Fix available

    ALPINE-CVE-2019-0211

    In Apache HTTP Server 2.4 releases 2.4.17 to 2.4.38, with MPM event, worker or prefork, code executing in less-privileged child processes or threads (including scripts executed by an in-process scripting interpreter) could execute arbitrary code with the privileges of the parent process (usually root) by manipulating the scoreboard. Non-Unix systems are not affected.

    • Update to 2.4.39-r0
    Published Updated
  11. ALPINE-CVE-2019-0217

    High · CVSS 7.5Fix available

    ALPINE-CVE-2019-0217

    In Apache HTTP Server 2.4 release 2.4.38 and prior, a race condition in mod_auth_digest when running in a threaded server could allow a user with valid credentials to authenticate using another username, bypassing configured access control restrictions.

    • Update to 2.4.39-r0
    Published Updated
  12. ALPINE-CVE-2019-0190

    High · CVSS 7.5Fix available

    ALPINE-CVE-2019-0190

    A bug exists in the way mod_ssl handled client renegotiations. A remote attacker could send a carefully crafted request that would cause mod_ssl to enter a loop leading to a denial of service. This bug can be only triggered with Apache HTTP Server version 2.4.37 when using OpenSSL version 1.1.1 or later, due to an interaction in changes to handling of renegotiation attempts.

    • Update to 2.4.38-r0
    Published Updated
  13. ALPINE-CVE-2018-17199

    High · CVSS 7.5Fix available

    ALPINE-CVE-2018-17199

    In Apache HTTP Server 2.4 release 2.4.37 and prior, mod_session checks the session expiry time before decoding the session. This causes session expiry time to be ignored for mod_session_cookie sessions since the expiry time is loaded when the session is decoded.

    • Update to 2.4.38-r0
    Published Updated
  14. ALPINE-CVE-2018-17189

    Medium · CVSS 5.3Fix available

    ALPINE-CVE-2018-17189

    In Apache HTTP server versions 2.4.37 and prior, by sending request bodies in a slow loris way to plain resources, the h2 stream for that request unnecessarily occupied a server thread cleaning up that incoming data. This affects only HTTP/2 (mod_http2) connections.

    • Update to 2.4.38-r0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →