ALPINE-CVE-2019-0190
ALPINE-CVE-2019-0190
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A bug exists in the way mod_ssl handled client renegotiations. A remote attacker could send a carefully crafted request that would cause mod_ssl to enter a loop leading to a denial of service. This bug can be only triggered with Apache HTTP Server version 2.4.37 when using OpenSSL version 1.1.1 or later, due to an interaction in changes to handling of renegotiation attempts.
CVSS 7.5 · High · Fix available
- Published
- Updated
Stack: system
Affected products and versions
apache2 Alpine:v3.10
- Affected ranges
- ECOSYSTEM: < 2.4.38-r0
Update to 2.4.38-r0
apache2 Alpine:v3.11
- Affected ranges
- ECOSYSTEM: < 2.4.38-r0
Update to 2.4.38-r0
apache2 Alpine:v3.12
- Affected ranges
- ECOSYSTEM: < 2.4.38-r0
Update to 2.4.38-r0
apache2 Alpine:v3.13
- Affected ranges
- ECOSYSTEM: < 2.4.38-r0
Update to 2.4.38-r0
apache2 Alpine:v3.14
- Affected ranges
- ECOSYSTEM: < 2.4.38-r0
Update to 2.4.38-r0
apache2 Alpine:v3.15
- Affected ranges
- ECOSYSTEM: < 2.4.38-r0
Update to 2.4.38-r0
apache2 Alpine:v3.16
- Affected ranges
- ECOSYSTEM: < 2.4.38-r0
Update to 2.4.38-r0
apache2 Alpine:v3.17
- Affected ranges
- ECOSYSTEM: < 2.4.38-r0
Update to 2.4.38-r0
apache2 Alpine:v3.18
- Affected ranges
- ECOSYSTEM: < 2.4.38-r0
Update to 2.4.38-r0
apache2 Alpine:v3.19
- Affected ranges
- ECOSYSTEM: < 2.4.38-r0
Update to 2.4.38-r0
apache2 Alpine:v3.20
- Affected ranges
- ECOSYSTEM: < 2.4.38-r0
Update to 2.4.38-r0
apache2 Alpine:v3.21
- Affected ranges
- ECOSYSTEM: < 2.4.38-r0
Update to 2.4.38-r0
apache2 Alpine:v3.22
- Affected ranges
- ECOSYSTEM: < 2.4.38-r0
Update to 2.4.38-r0
apache2 Alpine:v3.23
- Affected ranges
- ECOSYSTEM: < 2.4.38-r0
Update to 2.4.38-r0
apache2 Alpine:v3.24
- Affected ranges
- ECOSYSTEM: < 2.4.38-r0
Update to 2.4.38-r0
apache2 Alpine:v3.6
- Affected ranges
- ECOSYSTEM: < 2.4.38-r0
Update to 2.4.38-r0
apache2 Alpine:v3.7
- Affected ranges
- ECOSYSTEM: < 2.4.38-r0
Update to 2.4.38-r0
apache2 Alpine:v3.8
- Affected ranges
- ECOSYSTEM: < 2.4.38-r0
Update to 2.4.38-r0
apache2 Alpine:v3.9
- Affected ranges
- ECOSYSTEM: < 2.4.38-r0
Update to 2.4.38-r0