p PatchFirst

CVE-2015-0837

CVE-2015-0837

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The mpi_powm function in Libgcrypt before 1.6.3 and GnuPG before 1.4.19 allows attackers to obtain sensitive information by leveraging timing differences when accessing a pre-computed table during modular exponentiation, related to a "Last-Level Cache Side-Channel Attack."

CVSS 5.9 · Medium · EPSS 2.0% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • libgcrypt

    Versions
    • before 1.6.3: Affected

    No fix published

  • gnupg

    Versions
    • before 1.4.19: Affected

    No fix published

  • libgcrypt20 Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.6.3-2

    Update to 1.6.3-2

  • libgcrypt20 Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.6.3-2

    Update to 1.6.3-2

  • libgcrypt20 Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.6.3-2

    Update to 1.6.3-2

  • gnupg Ubuntu:14.04:LTS

    Versions
    • 1.4.14-1ubuntu2
    • 1.4.15-1.1ubuntu1
    • 1.4.15-1.1ubuntu2
    • 1.4.15-2ubuntu1
    • 1.4.16-1ubuntu1
    • 1.4.16-1ubuntu2
    • 1.4.16-1ubuntu2.1
    Affected ranges
    • ECOSYSTEM: < 1.4.16-1ubuntu2.3

    Update to 1.4.16-1ubuntu2.3

  • libgcrypt11 Ubuntu:14.04:LTS

    Versions
    • 1.5.0-3ubuntu3
    • 1.5.3-2ubuntu1
    • 1.5.3-2ubuntu4
    • 1.5.3-2ubuntu4.1
    Affected ranges
    • ECOSYSTEM: < 1.5.3-2ubuntu4.2

    Update to 1.5.3-2ubuntu4.2

  • libgcrypt20 Ubuntu:14.04:LTS

    Versions
    • 1.6.0-2
    • 1.6.0-2ubuntu2
    • 1.6.1-1
    • 1.6.1-2
    • 1.6.1-2ubuntu1
    Affected ranges
    • ECOSYSTEM: < 1.6.1-2ubuntu1.14.04.1

    Update to 1.6.1-2ubuntu1.14.04.1

Original sources

Check your server →