p PatchFirst

CVE-2016-6313

CVE-2016-6313

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The mixing functions in the random number generator in Libgcrypt before 1.5.6, 1.6.x before 1.6.6, and 1.7.x before 1.7.3 and GnuPG before 1.4.21 make it easier for attackers to obtain the values of 160 bits by leveraging knowledge of the previous 4640 bits.

CVSS 5.3 · Medium · EPSS 3.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • gnupg1 Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.4.21-1

    Update to 1.4.21-1

  • gnupg1 Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.4.21-1

    Update to 1.4.21-1

  • gnupg1 Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.4.21-1

    Update to 1.4.21-1

  • libgcrypt20 Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.7.3-1

    Update to 1.7.3-1

  • libgcrypt20 Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.7.3-1

    Update to 1.7.3-1

  • libgcrypt20 Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.7.3-1

    Update to 1.7.3-1

  • gnupg Ubuntu:14.04:LTS

    Versions
    • 1.4.14-1ubuntu2
    • 1.4.15-1.1ubuntu1
    • 1.4.15-1.1ubuntu2
    • 1.4.15-2ubuntu1
    • 1.4.16-1ubuntu1
    • 1.4.16-1ubuntu2
    • 1.4.16-1ubuntu2.1
    • 1.4.16-1ubuntu2.3
    Affected ranges
    • ECOSYSTEM: < 1.4.16-1ubuntu2.4

    Update to 1.4.16-1ubuntu2.4

  • libgcrypt11 Ubuntu:14.04:LTS

    Versions
    • 1.5.0-3ubuntu3
    • 1.5.3-2ubuntu1
    • 1.5.3-2ubuntu4
    • 1.5.3-2ubuntu4.1
    • 1.5.3-2ubuntu4.2
    • 1.5.3-2ubuntu4.3
    Affected ranges
    • ECOSYSTEM: < 1.5.3-2ubuntu4.4

    Update to 1.5.3-2ubuntu4.4

  • gnupg Ubuntu:16.04:LTS

    Versions
    • 1.4.18-7ubuntu1
    • 1.4.19-6ubuntu1
    • 1.4.20-1ubuntu1
    • 1.4.20-1ubuntu2
    • 1.4.20-1ubuntu3
    Affected ranges
    • ECOSYSTEM: < 1.4.20-1ubuntu3.1

    Update to 1.4.20-1ubuntu3.1

  • libgcrypt20 Ubuntu:16.04:LTS

    Versions
    • 1.6.3-2ubuntu1
    • 1.6.4-3
    • 1.6.4-4
    • 1.6.4-5
    • 1.6.5-2
    Affected ranges
    • ECOSYSTEM: < 1.6.5-2ubuntu0.2

    Update to 1.6.5-2ubuntu0.2

Original sources

Check your server →