p PatchFirst

PatchFirst · Latest vulnerabilities

gnupg1 vulnerabilities

Vulnerabilities published for gnupg1 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 5

  1. CVE-2017-7526

    Medium · CVSS 6.1EPSS 3.84%Fix available

    CVE-2017-7526

    libgcrypt before version 1.7.8 is vulnerable to a cache side-channel attack resulting into a complete break of RSA-1024 while using the left-to-right method for computing the sliding-window expansion. The same attack is believed to work on RSA-2048 with moderately more computation. This side-channel requires that attacker can run arbitrary software on the hardware where the private RSA key is used.

    • Update to 1.4.22-1
    Published Updated
  2. CVE-2018-12020

    High · CVSS 7.5EPSS 8.25%Fix available

    CVE-2018-12020

    mainproc.c in GnuPG before 2.2.8 mishandles the original filename during decryption and verification actions, which allows remote attackers to spoof the output that GnuPG sends on file descriptor 2 to other programs that use the "--status-fd 2" option. For example, the OpenPGP data might represent an original filename that contains line feed characters in conjunction with GOODSIG or VALIDSIG status codes.

    • Update to 1.4.22-5
    Published Updated
  3. CVE-2018-6829

    High · CVSS 7.5EPSS 1.78%No fix published

    CVE-2018-6829

    cipher/elgamal.c in Libgcrypt through 1.8.2, when used to encrypt messages directly, improperly encodes plaintexts, which allows attackers to obtain sensitive information by reading ciphertext data (i.e., it does not have semantic security in face of a ciphertext-only attack). The Decisional Diffie-Hellman (DDH) assumption does not hold for Libgcrypt's ElGamal implementation.

    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →