p PatchFirst

CVE-2017-12194

CVE-2017-12194

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A flaw was found in the way spice-client processed certain messages sent from the server. An attacker, having control of malicious spice-server, could use this flaw to crash the client or execute arbitrary code with permissions of the user running the client. spice-gtk versions through 0.34 are believed to be vulnerable.

CVSS 9.8 · Critical · EPSS 5.2% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • spice-gtk

    Versions
    • through 0.34: Affected

    No fix published

  • spice-gtk Debian:12

    Affected ranges
    • ECOSYSTEM: < 0.35-1

    Update to 0.35-1

  • spice-gtk Debian:13

    Affected ranges
    • ECOSYSTEM: < 0.35-1

    Update to 0.35-1

  • spice-gtk Debian:14

    Affected ranges
    • ECOSYSTEM: < 0.35-1

    Update to 0.35-1

  • spice Ubuntu:14.04:LTS

    Versions
    • 0.12.4-0nocelt1
    • 0.12.4-0nocelt1.1
    • 0.12.4-0nocelt1.1ubuntu1
    • 0.12.4-0nocelt2
    • 0.12.4-0nocelt2ubuntu1
    • 0.12.4-0nocelt2ubuntu1.1
    • 0.12.4-0nocelt2ubuntu1.2
    • 0.12.4-0nocelt2ubuntu1.3
    • 0.12.4-0nocelt2ubuntu1.4
    • 0.12.4-0nocelt2ubuntu1.5
    Affected ranges
    • ECOSYSTEM: < 0.12.4-0nocelt2ubuntu1.6

    Update to 0.12.4-0nocelt2ubuntu1.6

  • spice-protocol Ubuntu:16.04:LTS

    Versions
    • 0.12.7-1
    • 0.12.10-1
    Affected ranges
    • ECOSYSTEM: < 0.12.10-1ubuntu0.1

    Update to 0.12.10-1ubuntu0.1

  • spice Ubuntu:18.04:LTS

    Versions
    • 0.12.8-2.2
    • 0.14.0-1
    • 0.14.0-1ubuntu1
    • 0.14.0-1ubuntu2
    Affected ranges
    • ECOSYSTEM: < 0.14.0-1ubuntu2.1

    Update to 0.14.0-1ubuntu2.1

  • spice-gtk Ubuntu:18.04:LTS

    Versions
    • 0.33-3.3
    • 0.34-1.1
    • 0.34-1.1build1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →