p PatchFirst

PatchFirst · Latest vulnerabilities

spice-gtk vulnerabilities

Vulnerabilities published for spice-gtk in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 7

  1. CVE-2020-14355

    Medium · CVSS 6.6EPSS 2.66%Fix available

    CVE-2020-14355

    Multiple buffer overflow vulnerabilities were found in the QUIC image decoding process of the SPICE remote display system, before spice-0.14.2-1. Both the SPICE client (spice-gtk) and server are affected by these flaws. These flaws allow a malicious client or server to send specially crafted messages that, when processed by the QUIC image compression algorithm, result in a process crash or potential code execution.

    • Update to 0.39-1
    Published Updated
  2. CVE-2018-10873

    High · CVSS 8.3EPSS 3.93%Fix available

    CVE-2018-10873

    A vulnerability was discovered in SPICE before version 0.14.1 where the generated code used for demarshalling messages lacked sufficient bounds checks. A malicious client or server, after authentication, could send specially crafted messages to its peer which would result in a crash or, potentially, other impacts.

    • Update to 0.35-1
    Published Updated
  3. CVE-2017-12194

    Critical · CVSS 9.8EPSS 5.25%Fix available

    CVE-2017-12194

    A flaw was found in the way spice-client processed certain messages sent from the server. An attacker, having control of malicious spice-server, could use this flaw to crash the client or execute arbitrary code with permissions of the user running the client. spice-gtk versions through 0.34 are believed to be vulnerable.

    • Update to 0.35-1
    Published Updated
  4. CVE-2013-4324

    Not ratedEPSS 0.38%Fix available

    CVE-2013-4324

    spice-gtk 0.14, and possibly other versions, invokes the polkit authority using the insecure polkit_unix_process_new API function, which allows local users to bypass intended access restrictions by leveraging a PolkitUnixProcess PolkitSubject race condition via a (1) setuid process or (2) pkexec process, a related issue to CVE-2013-4288.

    • Update to 0.21-0nocelt1
    Published Updated
  5. CVE-2012-4425

    Not ratedEPSS 1.09%Public exploitFix available

    CVE-2012-4425

    libgio, when used in setuid or other privileged programs in spice-gtk and possibly other products, allows local users to gain privileges and execute arbitrary code via the DBUS_SYSTEM_BUS_ADDRESS environment variable. NOTE: it could be argued that this is a vulnerability in the applications that do not cleanse environment variables, not in libgio itself.

    • Update to 0.12-5
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →