p PatchFirst

PatchFirst · Latest vulnerabilities

spice-protocol vulnerabilities

Vulnerabilities published for spice-protocol in the last 30 days: 2. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 4

  1. CVE-2026-105958

    High · CVSS 7.5EPSS 0.25%No fix published

    Spice-server: spice: heap oob read/write via unchecked migration data offsets

    A flaw was found in spice-server. Multiple migration data handlers use client-supplied offsets from SPICE_MSGC_MIGRATE_DATA messages without bounds validation, allowing a malicious authenticated SPICE client during VM live migration to read arbitrary heap memory or trigger heap corruption via out-of-bounds read and write operations on the message buffer.

    Published Updated
  2. CVE-2026-105959

    High · CVSS 7.5EPSS 0.48%No fix published

    Spice-server: spice: heap buffer overflow via glz dictionary max_encoders integer truncation

    A flaw was found in spice-server. The GLZ encoder dictionary restore path truncates a size_t allocation size to int when calling the malloc callback, allowing a malicious authenticated SPICE client during VM live migration to trigger a massive heap buffer overflow by sending a crafted max_encoders value in migration data.

    Published Updated
  3. CVE-2018-10873

    High · CVSS 8.3EPSS 3.93%Fix available

    CVE-2018-10873

    A vulnerability was discovered in SPICE before version 0.14.1 where the generated code used for demarshalling messages lacked sufficient bounds checks. A malicious client or server, after authentication, could send specially crafted messages to its peer which would result in a crash or, potentially, other impacts.

    • Update to 0.12.10-1ubuntu0.2
    Published Updated
  4. CVE-2017-12194

    Critical · CVSS 9.8EPSS 5.25%Fix available

    CVE-2017-12194

    A flaw was found in the way spice-client processed certain messages sent from the server. An attacker, having control of malicious spice-server, could use this flaw to crash the client or execute arbitrary code with permissions of the user running the client. spice-gtk versions through 0.34 are believed to be vulnerable.

    • Update to 0.12.10-1ubuntu0.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →