p PatchFirst

CVE-2017-7241

CVE-2017-7241

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A cross-site scripting (XSS) vulnerability in the MantisBT Move Attachments page (move_attachments_page.php, part of admin tools) allows remote attackers to inject arbitrary code through a crafted 'type' parameter, if Content Security Protection (CSP) settings allows it. This is fixed in 1.3.9, 2.1.3, and 2.2.3. Note that this vulnerability is not exploitable if the admin tools directory is removed, as recommended in the "Post-installation and upgrade tasks" of the MantisBT Admin Guide. A reminder to do so is also displayed on the login page.

CVSS 4.8 · Medium · EPSS 0.9% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • mantisbt/mantisbt Packagist

    Affected ranges
    • ECOSYSTEM: < 1.3.9

    Update to 1.3.9

  • mantisbt/mantisbt Packagist

    Affected ranges
    • ECOSYSTEM: ≥ 2.0.0, < 2.1.3

    Update to 2.1.3

  • mantisbt/mantisbt Packagist

    Affected ranges
    • ECOSYSTEM: ≥ 2.2.0, < 2.2.3

    Update to 2.2.3

Original sources

Check your server →