CVE-2017-7526
CVE-2017-7526
This page contains facts from public vulnerability sources. Check the original advisory before updating.
libgcrypt before version 1.7.8 is vulnerable to a cache side-channel attack resulting into a complete break of RSA-1024 while using the left-to-right method for computing the sliding-window expansion. The same attack is believed to work on RSA-2048 with moderately more computation. This side-channel requires that attacker can run arbitrary software on the hardware where the private RSA key is used.
CVSS 6.1 · Medium · EPSS 3.8% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
libgcrypt
- Versions
- 1.7.8: Affected
No fix published
gnupg1 Debian:12
- Affected ranges
- ECOSYSTEM: < 1.4.22-1
Update to 1.4.22-1
gnupg1 Debian:13
- Affected ranges
- ECOSYSTEM: < 1.4.22-1
Update to 1.4.22-1
gnupg1 Debian:14
- Affected ranges
- ECOSYSTEM: < 1.4.22-1
Update to 1.4.22-1
libgcrypt20 Debian:12
- Affected ranges
- ECOSYSTEM: < 1.7.8-1
Update to 1.7.8-1
libgcrypt20 Debian:13
- Affected ranges
- ECOSYSTEM: < 1.7.8-1
Update to 1.7.8-1
libgcrypt20 Debian:14
- Affected ranges
- ECOSYSTEM: < 1.7.8-1
Update to 1.7.8-1
gnupg Ubuntu:14.04:LTS
- Versions
- 1.4.14-1ubuntu2
- 1.4.15-1.1ubuntu1
- 1.4.15-1.1ubuntu2
- 1.4.15-2ubuntu1
- 1.4.16-1ubuntu1
- 1.4.16-1ubuntu2
- 1.4.16-1ubuntu2.1
- 1.4.16-1ubuntu2.3
- 1.4.16-1ubuntu2.4
- 1.4.16-1ubuntu2.5
- Affected ranges
- ECOSYSTEM: < 1.4.16-1ubuntu2.6
Update to 1.4.16-1ubuntu2.6
libgcrypt11 Ubuntu:14.04:LTS
- Versions
- 1.5.0-3ubuntu3
- 1.5.3-2ubuntu1
- 1.5.3-2ubuntu4
- 1.5.3-2ubuntu4.1
- 1.5.3-2ubuntu4.2
- 1.5.3-2ubuntu4.3
- 1.5.3-2ubuntu4.4
- Affected ranges
- ECOSYSTEM: < 1.5.3-2ubuntu4.5
Update to 1.5.3-2ubuntu4.5
gnupg Ubuntu:16.04:LTS
- Versions
- 1.4.18-7ubuntu1
- 1.4.19-6ubuntu1
- 1.4.20-1ubuntu1
- 1.4.20-1ubuntu2
- 1.4.20-1ubuntu3
- 1.4.20-1ubuntu3.1
- 1.4.20-1ubuntu3.2
- Affected ranges
- ECOSYSTEM: < 1.4.20-1ubuntu3.3
Update to 1.4.20-1ubuntu3.3
libgcrypt20 Ubuntu:16.04:LTS
- Versions
- 1.6.3-2ubuntu1
- 1.6.4-3
- 1.6.4-4
- 1.6.4-5
- 1.6.5-2
- 1.6.5-2ubuntu0.2
- Affected ranges
- ECOSYSTEM: < 1.6.5-2ubuntu0.3
Update to 1.6.5-2ubuntu0.3
Original sources
- https://usn.ubuntu.com/3733-1/
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-7526
- http://www.securitytracker.com/id/1038915
- https://www.debian.org/security/2017/dsa-3960
- https://git.gnupg.org/cgi-bin/gitweb.cgi?p=libgcrypt.git%3Ba=commit%3Bh=78130828e9a140a9de4dafadbc844dbb64cb709a
- https://www.debian.org/security/2017/dsa-3901
- https://usn.ubuntu.com/3733-2/
- https://eprint.iacr.org/2017/627
- http://www.securityfocus.com/bid/99338
- https://lists.gnupg.org/pipermail/gnupg-announce/2017q2/000408.html
- https://git.gnupg.org/cgi-bin/gitweb.cgi?p=libgcrypt.git%3Ba=commit%3Bh=e6a3dc9900433bbc8ad362a595a3837318c28fa9
- https://git.gnupg.org/cgi-bin/gitweb.cgi?p=libgcrypt.git%3Ba=commit%3Bh=8725c99ffa41778f382ca97233183bcd687bb0ce
- https://nvd.nist.gov/vuln/detail/CVE-2017-7526