p PatchFirst

CVE-2019-1000011

CVE-2019-1000011

This page contains facts from public vulnerability sources. Check the original advisory before updating.

API Platform version from 2.2.0 to 2.3.5 contains an Incorrect Access Control vulnerability in GraphQL delete mutations that can result in a user authorized to delete a resource can delete any resource. This attack appears to be exploitable via the user must be authorized. This vulnerability appears to have been fixed in 2.3.6.

CVSS 6.5 · Medium · EPSS 1.0% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • api-platform/core Packagist

    Versions
    • v2.2.0
    • v2.2.1
    • v2.2.2
    • v2.2.3
    • v2.2.4
    • v2.2.5
    • v2.2.6
    • v2.2.7
    • v2.2.8
    • v2.2.9
    Affected ranges
    • ECOSYSTEM: ≥ 2.2.0, < 2.2.10

    Update to 2.2.10

  • api-platform/core Packagist

    Versions
    • v2.3.0
    • v2.3.1
    • v2.3.2
    • v2.3.3
    • v2.3.4
    • v2.3.5
    Affected ranges
    • ECOSYSTEM: ≥ 2.3.0, < 2.3.6

    Update to 2.3.6

Original sources

Check your server →