p PatchFirst

CVE-2019-10079

CVE-2019-10079

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Apache Traffic Server is vulnerable to HTTP/2 setting flood attacks. Earlier versions of Apache Traffic Server didn't limit the number of setting frames sent from the client using the HTTP/2 protocol. Users should upgrade to Apache Traffic Server 7.1.7, 8.0.4, or later versions.

CVSS 7.5 · High · EPSS 4.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • apache traffic server

    Versions
    • Apache Traffic Server 6.0.0 to 6.2.3, 7.0.0 to 7.1.6, and 8.0.0 to 8.0.3: Affected

    No fix published

  • trafficserver Debian:12

    Affected ranges
    • ECOSYSTEM: < 8.0.5+ds-1

    Update to 8.0.5+ds-1

  • trafficserver Ubuntu:16.04:LTS

    Versions
    • 5.3.0-2ubuntu1
    • 5.3.0-2ubuntu2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • trafficserver Ubuntu:18.04:LTS

    Versions
    • 7.0.0-5
    • 7.1.2+ds-2
    • 7.1.2+ds-2build1
    • 7.1.2+ds-3
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →