CVE-2019-12471
CVE-2019-12471
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Wikimedia MediaWiki 1.30.0 through 1.32.1 has XSS. Loading user JavaScript from a non-existent account allows anyone to create the account, and perform XSS on users loading that script. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.
CVSS 6.1 · Medium · EPSS 1.3% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
mediawiki Debian:12
- Affected ranges
- ECOSYSTEM: < 1:1.31.2-1
Update to 1:1.31.2-1
mediawiki Debian:13
- Affected ranges
- ECOSYSTEM: < 1:1.31.2-1
Update to 1:1.31.2-1
mediawiki Debian:14
- Affected ranges
- ECOSYSTEM: < 1:1.31.2-1
Update to 1:1.31.2-1
mediawiki/core Packagist
- Versions
- 1.27.0
- 1.27.1
- 1.27.2
- 1.27.3
- 1.27.4
- 1.27.5
- Affected ranges
- ECOSYSTEM: ≥ 1.27.0, < 1.27.6
Update to 1.27.6
mediawiki/core Packagist
- Versions
- 1.30.0
- 1.30.1
- Affected ranges
- ECOSYSTEM: ≥ 1.30.0, < 1.30.2
Update to 1.30.2
mediawiki/core Packagist
- Versions
- 1.31.0
- 1.31.1
- Affected ranges
- ECOSYSTEM: ≥ 1.31.0, < 1.31.2
Update to 1.31.2
mediawiki Ubuntu:18.04:LTS
- Versions
- 1:1.27.3-1
- 1:1.27.4-1
- 1:1.27.4-2
- 1:1.27.4-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published