p PatchFirst

CVE-2020-8192

CVE-2020-8192

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A denial of service vulnerability exists in Fastify v2.14.1 and v3.0.0-rc.4 that allows a malicious user to trigger resource exhaustion (when the allErrors option is used) with specially crafted schemas.

EPSS 1.2% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • fastify

    Versions
    • Fixed in v2.15.1 and v3.0.0-rc.5. v1 not affected.: Affected

    No fix published

  • fastify npm

    Affected ranges
    • SEMVER: < 2.15.1

    Update to 2.15.1

Original sources

Check your server →