p PatchFirst

CVE-2021-21306

CVE-2021-21306 · Denial of Service in Marked

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Marked is an open-source markdown parser and compiler (npm package "marked"). In marked from version 1.1.1 and before version 2.0.0, there is a Regular expression Denial of Service vulnerability. This vulnerability can affect anyone who runs user generated code through marked. This vulnerability is fixed in version 2.0.0.

CVSS 5.3 · Medium · EPSS 2.5% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • marked

    Versions
    • >= 1.1.1, < 2.0.0: Affected

    No fix published

  • marked npm

    Affected ranges
    • SEMVER: ≥ 1.1.1, < 2.0.0

    Update to 2.0.0

Original sources

Check your server →