p PatchFirst

PatchFirst · Latest vulnerabilities

ckeditor3 vulnerabilities

Vulnerabilities published for ckeditor3 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 8

  1. CVE-2024-24816

    Medium · CVSS 6.1EPSS 1.65%No fix published

    Cross-site scripting (XSS) vulnerability in samples with enabled the preview feature

    CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. A cross-site scripting vulnerability vulnerability has been discovered in versions prior to 4.24.0-lts in samples that use the `preview` feature. All integrators that use these samples in the production code can be affected. The vulnerability allows an attacker to execute JavaScript code by abusing the misconfigured preview feature. It affects all users using the CKEditor 4 at version < 4.24.0-lts with affected samples used in a production environment. A fix is available in version 4.24.0-lts.

    Published Updated
  2. CVE-2024-24815

    Medium · CVSS 6.1EPSS 0.71%No fix published

    CKEditor4 Cross-site scripting (XSS) vulnerability caused by incorrect CDATA detection

    CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. A cross-site scripting vulnerability has been discovered in the core HTML parsing module in versions of CKEditor4 prior to 4.24.0-lts. It may affect all editor instances that enabled full-page editing mode or enabled CDATA elements in Advanced Content Filtering configuration (defaults to `script` and `style` elements). The vulnerability allows attackers to inject malformed HTML content bypassing Advanced Content Filtering mechanism, which could result in executing JavaScript code. An attacker could abuse faulty CDATA content detection and use it to prepare an intentional at

    Published Updated
  3. CVE-2023-28439

    Medium · CVSS 4.7EPSS 0.73%No fix published

    ckeditor4 plugins vulnerable to cross-site scripting caused by the editor instance destroying process

    CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. A cross-site scripting vulnerability has been discovered affecting Iframe Dialog and Media Embed packages. The vulnerability may trigger a JavaScript code after fulfilling special conditions: using one of the affected packages on a web page with missing proper Content Security Policy configuration; initializing the editor on an element and using an element other than `<textarea>` as a base; and destroying the editor instance. This vulnerability might affect a small percentage of integrators that depend on dynamic editor initialization/destroy mechanism. A fix is available

    Published Updated
  4. CVE-2022-24728

    Medium · CVSS 5.4EPSS 1.2%No fix published

    Cross-site Scripting in CKEditor4

    CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. A vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4 prior to version 4.18.0. The vulnerability allows someone to inject malformed HTML bypassing content sanitization, which could result in executing JavaScript code. This problem has been patched in version 4.18.0. There are currently no known workarounds.

    Published Updated
  5. CVE-2021-41165

    High · CVSS 8.2EPSS 1.57%No fix published

    HTML comments vulnerability allowing to execute JavaScript code

    CKEditor4 is an open source WYSIWYG HTML editor. In affected version a vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4. The vulnerability allowed to inject malformed comments HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.17.0. The problem has been recognized and patched. The fix will be available in version 4.17.0.

    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →