CVE-2022-25147
CVE-2022-25147 · Apache Portable Runtime Utility (APR-util): out-of-bounds writes in the apr_base64 family of functions
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Integer Overflow or Wraparound vulnerability in apr_base64 functions of Apache Portable Runtime Utility (APR-util) allows an attacker to write beyond bounds of a buffer. This issue affects Apache Portable Runtime Utility (APR-util) 1.6.1 and prior versions.
CVSS 6.5 · Medium · EPSS 1.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
apache portable runtime utility (apr-util)
- Versions
- ≥ 0, ≤ 1.6.1: Affected (semver)
No fix published
apr-util Debian:12
- Affected ranges
- ECOSYSTEM: < 1.6.3-1
Update to 1.6.3-1
apr-util Debian:13
- Affected ranges
- ECOSYSTEM: < 1.6.3-1
Update to 1.6.3-1
apr-util Debian:14
- Affected ranges
- ECOSYSTEM: < 1.6.3-1
Update to 1.6.3-1
apr-util Ubuntu:Pro:14.04:LTS
- Versions
- 1.5.2-1
- 1.5.2-1build1
- 1.5.2-2ubuntu1
- 1.5.3-1
- 1.5.3-1ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: < 1.5.3-1ubuntu0.1~esm2
Update to 1.5.3-1ubuntu0.1~esm2
apr-util Ubuntu:Pro:16.04:LTS
- Versions
- 1.5.4-1
- 1.5.4-1build1
- 1.5.4-1ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: < 1.5.4-1ubuntu0.1~esm2
Update to 1.5.4-1ubuntu0.1~esm2
apr-util Ubuntu:18.04:LTS
- Versions
- 1.6.0-2
- 1.6.1-1
- 1.6.1-1ubuntu2
- 1.6.1-2
- Affected ranges
- ECOSYSTEM: < 1.6.1-2ubuntu0.1
Update to 1.6.1-2ubuntu0.1
apr-util Ubuntu:20.04:LTS
- Versions
- 1.6.1-4build1
- 1.6.1-4ubuntu1
- 1.6.1-4ubuntu2
- Affected ranges
- ECOSYSTEM: < 1.6.1-4ubuntu2.1
Update to 1.6.1-4ubuntu2.1
apr-util Ubuntu:22.04:LTS
- Versions
- 1.6.1-5ubuntu2
- 1.6.1-5ubuntu3
- 1.6.1-5ubuntu4
- Affected ranges
- ECOSYSTEM: < 1.6.1-5ubuntu4.22.04.1
Update to 1.6.1-5ubuntu4.22.04.1