CVE-2024-28746
CVE-2024-28746 · Apache Airflow: Ignored Airflow Permissions
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Apache Airflow, versions 2.8.0 through 2.8.2, has a vulnerability that allows an authenticated user with limited permissions to access resources such as variables, connections, etc from the UI which they do not have permission to access. Users of Apache Airflow are recommended to upgrade to version 2.8.3 or newer to mitigate the risk associated with this vulnerability
CVSS 8.1 · High · EPSS 1.3% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
apache airflow
- Versions
- ≥ 2.8.0, < 2.8.3: Affected (semver)
Update to 2.8.3
apache-airflow PyPI
- Versions
- 2.8.0
- 2.8.1
- 2.8.1rc1
- 2.8.2
- 2.8.2rc1
- 2.8.2rc2
- 2.8.2rc3
- Affected ranges
- ECOSYSTEM: ≥ 2.8.0, < 2.8.3rc1
Update to 2.8.3rc1