p PatchFirst

CVE-2024-45605

CVE-2024-45605 · Improper authorization on deletion of user issue alert notifications in sentry

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Sentry is a developer-first error tracking and performance monitoring platform. An authenticated user delete the user issue alert notifications for arbitrary users given a know alert ID. A patch was issued to ensure authorization checks are properly scoped on requests to delete user alert notifications. Sentry SaaS users do not need to take any action. Self-Hosted Sentry users should upgrade to version 24.9.0 or higher. There are no known workarounds for this vulnerability.

CVSS 6.5 · Medium · EPSS 0.4% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • sentry

    Versions
    • >=23.9.0, < 24.9.0: Affected

    No fix published

  • sentry PyPI

    Affected ranges
    • ECOSYSTEM: ≥ 23.9.0, < 24.9.0

    Update to 24.9.0

Original sources

Check your server →