CVE-2025-31128
CVE-2025-31128 · gifplayer XSS vulnerability
This page contains facts from public vulnerability sources. Check the original advisory before updating.
gifplayer is a customizable jquery plugin to play and stop animated gifs. gifplayer contains a cross-site scripting (XSS) vulnerability. This vulnerability is fixed in 0.3.7.
CVSS 6.9 · Medium · EPSS 0.5% · Fix available
- Published
- Updated
Affected products and versions
gifplayer
- Versions
- < 0.3.7: Affected
No fix published
gifplayer npm
- Affected ranges
- SEMVER: < 0.3.7
Update to 0.3.7
drupal/gifplayer Packagist:https://packages.drupal.org/8
- Affected ranges
- ECOSYSTEM: < 1.5.0
- ECOSYSTEM: ≥ 2.0.1, < 2.0.4
Update to 1.5.0; Update to 2.0.4