p PatchFirst

CVE-2025-4011

CVE-2025-4011 · Redmine Custom Query cross site scripting

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A vulnerability has been found in Redmine 6.0.0/6.0.1/6.0.2/6.0.3 and classified as problematic. This vulnerability affects unknown code of the component Custom Query Handler. The manipulation of the argument Name leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 6.0.4 is able to address this issue. It is recommended to upgrade the affected component.

CVSS 5.1 · Medium · EPSS 0.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • redmine

    Versions
    • 6.0.0: Affected
    • 6.0.1: Affected
    • 6.0.2: Affected
    • 6.0.3: Affected

    No fix published

  • redmine Debian:13

    Affected ranges
    • ECOSYSTEM: < 6.0.4+ds-1

    Update to 6.0.4+ds-1

  • redmine Debian:14

    Affected ranges
    • ECOSYSTEM: < 6.0.4+ds-1

    Update to 6.0.4+ds-1

  • redmine Ubuntu:16.04:LTS

    Versions
    • 3.0~20140825-8
    • 3.2.0-1
    • 3.2.0-3
    • 3.2.1-1
    • 3.2.1-2
    • 3.2.1-2ubuntu0.2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • redmine Ubuntu:18.04:LTS

    Versions
    • 3.3.1-4
    • 3.4.2-1
    • 3.4.4-1
    • 3.4.4-1ubuntu0.1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • redmine Ubuntu:20.04:LTS

    Versions
    • 4.0.4-1
    • 4.0.4-3
    • 4.0.6-2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →