p PatchFirst

CVE-2025-59527

CVE-2025-59527 · FlowiseAI/Flowise has Server-Side Request Forgery (SSRF) vulnerability

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Flowise is a drag & drop user interface to build a customized large language model flow. In version 3.0.5, a Server-Side Request Forgery (SSRF) vulnerability was discovered in the /api/v1/fetch-links endpoint of the Flowise application. This vulnerability allows an attacker to use the Flowise server as a proxy to access internal network web services and explore their link structures. This issue has been patched in version 3.0.6.

CVSS 7.5 · High · EPSS 5.2% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • flowise

    Versions
    • = 3.0.5: Affected

    No fix published

  • flowise npm

    Versions
    • 3.0.5
    Affected ranges
    • SEMVER: ≥ 3.0.5, < 3.0.6

    Update to 3.0.6

Original sources

Check your server →