CVE-2026-105848
CVE-2026-105848 · Payload: Insufficient Access Control in Stripe REST Proxy
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Payload is a free and open source headless content management system. In @payloadcms/plugin-stripe versions before 3.90.0 and canary versions before 4.0.0-canary.34, an authenticated user who can reach the enabled optional Stripe REST proxy can perform unintended Stripe operations. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.
CVSS 6.4 · Medium · EPSS 0.2% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
payload
- Versions
- < 3.90.0: Affected
- >= 4.0.0-canary.0, < 4.0.0-canary.34: Affected
No fix published
plugin-stripe
- Versions
- < 3.90.0: Affected
- >= 4.0.0-canary.0, < 4.0.0-canary.34: Affected
No fix published
@payloadcms/plugin-stripe npm
- Affected ranges
- SEMVER: < 3.90.0
Update to 3.90.0
@payloadcms/plugin-stripe npm
- Affected ranges
- SEMVER: ≥ 4.0.0-canary.0, < 4.0.0-canary.34
Update to 4.0.0-canary.34