p PatchFirst

CVE-2026-43944

CVE-2026-43944 · electerm: dangerous code can be run through links or command line

This page contains facts from public vulnerability sources. Check the original advisory before updating.

electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. From versions 3.0.6 to before 3.8.15, electerm is vulnerable to arbitrary local code execution via deep links, CLI --opts, or crafted shortcuts. Exploit requires clicking a crafted electerm://... link or opening a crafted shortcut/command that launches electerm with attacker-controlled opts. This issue has been patched in version 3.8.15.

CVSS 9.4 · Critical · EPSS 0.4% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • electerm

    Versions
    • >= 3.0.6, < 3.8.15: Affected

    No fix published

  • electerm npm

    Affected ranges
    • SEMVER: ≥ 3.0.6, < 3.8.8

    Update to 3.8.8

Original sources

Check your server →