p PatchFirst

PatchFirst · Latest vulnerabilities

gnupg2 vulnerabilities · Page 2

Vulnerability published for gnupg2 in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 25

  1. CVE-2006-6169

    Not ratedEPSS 3.46%Fix available

    CVE-2006-6169

    Heap-based buffer overflow in the ask_outfile_name function in openfile.c for GnuPG (gpg) 1.4 and 2.0, when running interactively, might allow attackers to execute arbitrary code via messages with "C-escape" expansions, which cause the make_printable_string function to return a longer string than expected while constructing a prompt.

    • Update to 2.0.0-5.1
    Published Updated
  2. CVE-2006-3082

    Not ratedEPSS 7.31%Public exploitFix available

    CVE-2006-3082

    parse-packet.c in GnuPG (gpg) 1.4.3 and 1.9.20, and earlier versions, allows remote attackers to cause a denial of service (gpg crash) and possibly overwrite memory via a message packet with a large length (long user ID string), which could lead to an integer overflow, as demonstrated using the --no-armor option.

    • Update to 1.9.20-1.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →