CVE-2018-10873
CVE-2018-10873
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A vulnerability was discovered in SPICE before version 0.14.1 where the generated code used for demarshalling messages lacked sufficient bounds checks. A malicious client or server, after authentication, could send specially crafted messages to its peer which would result in a crash or, potentially, other impacts.
CVSS 8.3 · High · EPSS 3.9% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
spice:
- Versions
- 0.14.1: Affected
No fix published
spice Debian:12
- Affected ranges
- ECOSYSTEM: < 0.14.0-1.1
Update to 0.14.0-1.1
spice Debian:13
- Affected ranges
- ECOSYSTEM: < 0.14.0-1.1
Update to 0.14.0-1.1
spice Debian:14
- Affected ranges
- ECOSYSTEM: < 0.14.0-1.1
Update to 0.14.0-1.1
spice-gtk Debian:12
- Affected ranges
- ECOSYSTEM: < 0.35-1
Update to 0.35-1
spice-gtk Debian:13
- Affected ranges
- ECOSYSTEM: < 0.35-1
Update to 0.35-1
spice-gtk Debian:14
- Affected ranges
- ECOSYSTEM: < 0.35-1
Update to 0.35-1
spice Ubuntu:14.04:LTS
- Versions
- 0.12.4-0nocelt1
- 0.12.4-0nocelt1.1
- 0.12.4-0nocelt1.1ubuntu1
- 0.12.4-0nocelt2
- 0.12.4-0nocelt2ubuntu1
- 0.12.4-0nocelt2ubuntu1.1
- 0.12.4-0nocelt2ubuntu1.2
- 0.12.4-0nocelt2ubuntu1.3
- 0.12.4-0nocelt2ubuntu1.4
- 0.12.4-0nocelt2ubuntu1.5
- 0.12.4-0nocelt2ubuntu1.6
- Affected ranges
- ECOSYSTEM: < 0.12.4-0nocelt2ubuntu1.7
Update to 0.12.4-0nocelt2ubuntu1.7
spice-protocol Ubuntu:16.04:LTS
- Versions
- 0.12.7-1
- 0.12.10-1
- 0.12.10-1ubuntu0.1
- Affected ranges
- ECOSYSTEM: < 0.12.10-1ubuntu0.2
Update to 0.12.10-1ubuntu0.2
spice-gtk Ubuntu:16.04:LTS
- Versions
- 0.28-1ubuntu1
- 0.29-1
- 0.30-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
spice Ubuntu:18.04:LTS
- Versions
- 0.12.8-2.2
- 0.14.0-1
- 0.14.0-1ubuntu1
- 0.14.0-1ubuntu2
- 0.14.0-1ubuntu2.1
- Affected ranges
- ECOSYSTEM: < 0.14.0-1ubuntu2.2
Update to 0.14.0-1ubuntu2.2
spice-gtk Ubuntu:18.04:LTS
- Versions
- 0.33-3.3
- 0.34-1.1
- 0.34-1.1build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://www.debian.org/security/2018/dsa-4319
- https://lists.debian.org/debian-lts-announce/2018/08/msg00035.html
- https://usn.ubuntu.com/3751-1/
- https://access.redhat.com/errata/RHSA-2018:2732
- https://lists.debian.org/debian-lts-announce/2018/08/msg00037.html
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10873
- https://access.redhat.com/errata/RHSA-2018:2731
- https://access.redhat.com/errata/RHSA-2018:3470
- https://lists.debian.org/debian-lts-announce/2018/08/msg00038.html
- http://www.securityfocus.com/bid/105152
- https://gitlab.freedesktop.org/spice/spice-common/commit/bb15d4815ab586b4c4a20f4a565970a44824c42c
- https://nvd.nist.gov/vuln/detail/CVE-2018-10873