p PatchFirst

PatchFirst · Latest vulnerabilities

sssd vulnerabilities · Page 3

Vulnerabilities published for sssd in the last 30 days: 23. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 52

  1. CVE-2019-3811

    Medium · CVSS 4.1EPSS 0.7%Fix available

    CVE-2019-3811

    A vulnerability was found in sssd. If a user was configured with no home directory set, sssd would return '/' (the root directory) instead of '' (the empty string / no home directory). This could impact services that restrict the user's filesystem access to within their home directory through chroot() etc. All versions before 2.1 are vulnerable.

    • Update to 2.2.0-1
    Published Updated
  2. CVE-2017-12173

    Medium · CVSS 4.3EPSS 1.5%Fix available

    CVE-2017-12173

    It was found that sssd's sysdb_search_user_by_upn_res() function before 1.16.0 did not sanitize requests when querying its local cache and was vulnerable to injection. In a centralized login environment, if a password hash was locally cached for a given user, an authenticated attacker could use this flaw to retrieve it.

    • Update to 1.15.3-2
    Published Updated
  3. CVE-2018-10852

    Low · CVSS 3.8EPSS 1.5%Fix available

    CVE-2018-10852

    The UNIX pipe which sudo uses to contact SSSD and read the available sudo rules from SSSD has too wide permissions, which means that anyone who can send a message using the same raw protocol that sudo and SSSD use can read the sudo rules available for any user. This affects versions of SSSD before 1.16.3.

    • Update to 1.16.3-1
    Published Updated
  4. CVE-2015-5292

    Not ratedEPSS 3.67%Fix available

    CVE-2015-5292

    Memory leak in the Privilege Attribute Certificate (PAC) responder plugin (sssd_pac_plugin.so) in System Security Services Daemon (SSSD) 1.10 before 1.13.1 allows remote authenticated users to cause a denial of service (memory consumption) via a large number of logins that trigger parsing of PAC blobs during Kerberos authentication.

    • Update to 1.13.1-1
    Published Updated
  5. CVE-2013-0220

    Not ratedEPSS 3.32%Fix available

    CVE-2013-0220

    The (1) sss_autofs_cmd_getautomntent and (2) sss_autofs_cmd_getautomntbyname function in responder/autofs/autofssrv_cmd.c and the (3) ssh_cmd_parse_request function in responder/ssh/sshsrv_cmd.c in System Security Services Daemon (SSSD) before 1.9.4 allow remote attackers to cause a denial of service (out-of-bounds read, crash, and restart) via a crafted SSSD packet.

    • Update to 1.8.4-2
    Published Updated
  6. CVE-2010-0014

    Not ratedEPSS 0.69%Fix available

    CVE-2010-0014

    System Security Services Daemon (SSSD) before 1.0.1, when the krb5 auth_provider is configured but the KDC is unreachable, allows physically proximate attackers to authenticate, via an arbitrary password, to the screen-locking program on a workstation that has any user's Kerberos ticket-granting ticket (TGT); and might allow remote attackers to bypass intended access restrictions via vectors involving an arbitrary password in conjunction with a valid TGT.

    • Update to 1.0.5-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →