p PatchFirst

PatchFirst · Latest vulnerabilities

cacti vulnerabilities · Page 9

Vulnerabilities published for cacti in the last 30 days: 3. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 175

  1. CVE-2006-6799

    Not ratedEPSS 2.59%Fix available

    CVE-2006-6799

    SQL injection vulnerability in Cacti 0.8.6i and earlier, when register_argc_argv is enabled, allows remote attackers to execute arbitrary SQL commands via the (1) second or (2) third arguments to cmd.php. NOTE: this issue can be leveraged to execute arbitrary commands since the SQL query results are later used in the polling_items array and popen function.

    • Update to 0.8.6i-3
    Published Updated
  2. CVE-2006-0806

    Not ratedEPSS 6.01%Public exploitFix available

    CVE-2006-0806

    Multiple cross-site scripting (XSS) vulnerabilities in ADOdb 4.71, as used in multiple packages such as phpESP, allow remote attackers to inject arbitrary web script or HTML via (1) the next_page parameter in adodb-pager.inc.php and (2) other unspecified vectors related to PHP_SELF.

    • Update to 0.8.6d-1
    Published Updated
  3. CVE-2006-0147

    Not ratedEPSS 13.06%Public exploitFix available

    CVE-2006-0147

    Dynamic code evaluation vulnerability in tests/tmssql.php test script in ADOdb for PHP before 4.70, as used in multiple products including (1) Mantis, (2) PostNuke, (3) Moodle, (4) Cacti, (5) Xaraya, (6) PhpOpenChat, possibly (7) MAXdev MD-Pro, and (8) Simplog, allows remote attackers to execute arbitrary PHP functions via the do parameter, which is saved in a variable that is then executed as a function, as demonstrated using phpinfo.

    • Update to 0.8.6d-1
    Published Updated
  4. CVE-2006-0146

    Not ratedEPSS 13.24%Public exploitFix available

    CVE-2006-0146

    The server.php test script in ADOdb for PHP before 4.70, as used in multiple products including (1) Mantis, (2) PostNuke, (3) Moodle, (4) Cacti, (5) Xaraya, (6) PHPOpenChat, (7) MAXdev MD-Pro, and (8) MediaBeez, when the MySQL root password is empty, allows remote attackers to execute arbitrary SQL commands via the sql parameter.

    • Update to 0.8.6d-1
    Published Updated
  5. CVE-2005-2148

    Not ratedEPSS 3.4%Fix available

    CVE-2005-2148

    Cacti 0.8.6e and earlier does not perform proper input validation to protect against common attacks, which allows remote attackers to execute arbitrary commands or SQL by sending a legitimate value in a POST request or cookie, then specifying the attack string in the URL, which causes the get_request_var function to return the wrong value in the $_REQUEST variable, which is cleansed while the original malicious $_GET value remains unmodified, as demonstrated in (1) graph_image.php and (2) graph.php.

    • Update to 0.8.6f-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →