p PatchFirst

PatchFirst · Latest vulnerabilities

cacti vulnerabilities · Page 8

Vulnerabilities published for cacti in the last 30 days: 3. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 175

  1. CVE-2010-2545

    Not ratedEPSS 1.8%Fix available

    CVE-2010-2545

    Multiple cross-site scripting (XSS) vulnerabilities in Cacti before 0.8.7g, as used in Red Hat High Performance Computing (HPC) Solution and other products, allow remote attackers to inject arbitrary web script or HTML via (1) the name element in an XML template to templates_import.php; and allow remote authenticated administrators to inject arbitrary web script or HTML via vectors related to (2) cdef.php, (3) data_input.php, (4) data_queries.php, (5) data_sources.php, (6) data_templates.php, (7) gprint_presets.php, (8) graph.php, (9) graphs_new.php, (10) graphs.php, (11) graph_templates_inputs.php, (12) graph_templates_items.php, (13) graph_

    • Update to 0.8.7g-1
    Published Updated
  2. CVE-2010-2543

    Not ratedEPSS 3.87%Public exploitFix available

    CVE-2010-2543

    Cross-site scripting (XSS) vulnerability in include/top_graph_header.php in Cacti before 0.8.7g allows remote attackers to inject arbitrary web script or HTML via the graph_start parameter to graph.php. NOTE: this vulnerability exists because of an incorrect fix for CVE-2009-4032.2.b.

    • Update to 0.8.7g-1
    Published Updated
  3. CVE-2010-1645

    Not ratedEPSS 2.8%Fix available

    CVE-2010-1645

    Cacti before 0.8.7f, as used in Red Hat High Performance Computing (HPC) Solution and other products, allows remote authenticated administrators to execute arbitrary commands via shell metacharacters in (1) the FQDN field of a Device or (2) the Vertical Label field of a Graph Template.

    • Update to 0.8.7g-1
    Published Updated
  4. CVE-2010-1644

    Not ratedEPSS 1.86%Fix available

    CVE-2010-1644

    Multiple cross-site scripting (XSS) vulnerabilities in Cacti before 0.8.7f, as used in Red Hat High Performance Computing (HPC) Solution and other products, allow remote attackers to inject arbitrary web script or HTML via the (1) hostname or (2) description parameter to host.php, or (3) the host_id parameter to data_sources.php.

    • Update to 0.8.7g-1
    Published Updated
  5. CVE-2010-2092

    Not ratedEPSS 1.37%Fix available

    CVE-2010-2092

    SQL injection vulnerability in graph.php in Cacti 0.8.7e and earlier allows remote attackers to execute arbitrary SQL commands via a crafted rra_id parameter in a GET request in conjunction with a valid rra_id value in a POST request or a cookie, which causes the POST or cookie value to bypass the validation routine, but inserts the $_GET value into the resulting query.

    • Update to 0.8.7e-4
    Published Updated
  6. CVE-2009-4032

    Not ratedEPSS 5.74%Public exploitFix available

    CVE-2009-4032

    Multiple cross-site scripting (XSS) vulnerabilities in Cacti 0.8.7e allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) graph.php, (2) include/top_graph_header.php, (3) lib/html_form.php, and (4) lib/timespan_settings.php, as demonstrated by the (a) graph_end or (b) graph_start parameters to graph.php; (c) the date1 parameter in a tree action to graph_view.php; and the (d) page_refresh and (e) default_dual_pane_width parameters to graph_settings.php.

    • Update to 0.8.7e-1.1
    Published Updated
  7. CVE-2008-0785

    Not ratedEPSS 3.44%Public exploitFix available

    CVE-2008-0785

    Multiple SQL injection vulnerabilities in Cacti 0.8.7 before 0.8.7b and 0.8.6 before 0.8.6k allow remote authenticated users to execute arbitrary SQL commands via the (1) graph_list parameter to graph_view.php, (2) leaf_id and id parameters to tree.php, (3) local_graph_id parameter to graph_xport.php, and (4) login_username parameter to index.php/login.

    • Update to 0.8.7b-1
    Published Updated
  8. CVE-2008-0783

    Not ratedEPSS 5.25%Public exploitFix available

    CVE-2008-0783

    Multiple cross-site scripting (XSS) vulnerabilities in Cacti 0.8.7 before 0.8.7b and 0.8.6 before 0.8.6k allow remote attackers to inject arbitrary web script or HTML via (1) the view_type parameter to graph.php; (2) the filter parameter to graph_view.php; (3) the action parameter to the draw_navigation_text function in lib/functions.php, reachable through index.php (aka the login page) or data_input.php; or (4) the login_username parameter to index.php.

    • Update to 0.8.7b-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →