p PatchFirst

PatchFirst · Latest vulnerabilities

glibc vulnerabilities · Page 5

Vulnerabilities published for glibc in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 169

  1. CVE-2017-16997

    High · CVSS 7.8EPSS 2.9%Fix available

    CVE-2017-16997

    elf/dl-load.c in the GNU C Library (aka glibc or libc6) 2.19 through 2.26 mishandles RPATH and RUNPATH containing $ORIGIN for a privileged (setuid or AT_SECURE) program, which allows local users to gain privileges via a Trojan horse library in the current working directory, related to the fillin_rpath and decompose_rpath functions. This is associated with misinterpretion of an empty RPATH/RUNPATH token as the "./" directory. NOTE: this configuration of RPATH/RUNPATH for a privileged program is apparently very uncommon; most likely, no such program is shipped with any common Linux distribution.

    • Update to 2.25-6
    Published Updated
  2. CVE-2017-1000366

    High · CVSS 7.8EPSS 2.73%Public exploitFix available

    CVE-2017-1000366

    glibc contains a vulnerability that allows specially crafted LD_LIBRARY_PATH values to manipulate the heap/stack, causing them to alias, potentially resulting in arbitrary code execution. Please note that additional hardening changes have been made to glibc to prevent manipulation of stack and heap memory but these issues are not directly exploitable, as such they have not been given a CVE. This affects glibc 2.25 and earlier.

    • Update to 2.24-12
    Published Updated
  3. CVE-2015-8983

    High · CVSS 8.1EPSS 4.01%Fix available

    CVE-2015-8983

    Integer overflow in the _IO_wstr_overflow function in libio/wstrops.c in the GNU C Library (aka glibc or libc6) before 2.22 allows context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via vectors related to computing a size in bytes, which triggers a heap-based buffer overflow.

    • Update to 2.21-1
    Published Updated
  4. CVE-2016-10228

    Medium · CVSS 5.9EPSS 4.11%Fix available

    CVE-2016-10228

    The iconv program in the GNU C Library (aka glibc or libc6) 2.31 and earlier, when invoked with multiple suffixes in the destination encoding (TRANSLATE or IGNORE) along with the -c option, enters an infinite loop when processing invalid multi-byte input sequences, leading to a denial of service.

    • Update to 2.31-3
    Published Updated
  5. CVE-2016-5417

    High · CVSS 7.5EPSS 3.36%Fix available

    CVE-2016-5417

    Memory leak in the __res_vinit function in the IPv6 name server management code in libresolv in GNU C Library (aka glibc or libc6) before 2.24 allows remote attackers to cause a denial of service (memory consumption) by leveraging partial initialization of internal resolver data structures.

    • Update to 2.22-4
    Published Updated
  6. CVE-2016-6323

    High · CVSS 7.5EPSS 3.87%Fix available

    CVE-2016-6323

    The makecontext function in the GNU C Library (aka glibc or libc6) before 2.25 creates execution contexts incompatible with the unwinder on ARM EABI (32-bit) platforms, which might allow context-dependent attackers to cause a denial of service (hang), as demonstrated by applications compiled using gccgo, related to backtrace generation.

    • Update to 2.24-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →