p PatchFirst

PatchFirst · Latest vulnerabilities

glibc vulnerabilities · Page 4

Vulnerabilities published for glibc in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 169

  1. CVE-2019-19126

    Low · CVSS 3.3EPSS 0.41%Fix available

    CVE-2019-19126

    On the x86-64 architecture, the GNU C Library (aka glibc) before 2.31 fails to ignore the LD_PREFER_MAP_32BIT_EXEC environment variable during program execution after a security transition, allowing local attackers to restrict the possible mapping addresses for loaded libraries and thus bypass ASLR for a setuid program.

    • Update to 2.29-8
    Published Updated
  2. CVE-2019-1010023

    Medium · CVSS 5.4EPSS 3.07%No fix published

    CVE-2019-1010023

    GNU Libc current is affected by: Re-mapping current loaded library with malicious ELF file. The impact is: In worst case attacker may evaluate privileges. The component is: libld. The attack vector is: Attacker sends 2 ELF files to victim and asks to run ldd on it. ldd execute code. NOTE: Upstream comments indicate "this is being treated as a non-security bug and no real threat.

    Published Updated
  3. CVE-2019-1010022

    Critical · CVSS 9.8EPSS 3.25%No fix published

    CVE-2019-1010022

    GNU Libc current is affected by: Mitigation bypass. The impact is: Attacker may bypass stack guard protection. The component is: nptl. The attack vector is: Exploit stack buffer overflow vulnerability and use this bypass vulnerability to bypass stack guard. NOTE: Upstream comments indicate "this is being treated as a non-security bug and no real threat.

    Published Updated
  4. CVE-2006-7254

    Medium · CVSS 5.5EPSS 0.3%Fix available

    CVE-2006-7254

    The nscd daemon in the GNU C Library (glibc) before version 2.5 does not close incoming client sockets if they cannot be handled by the daemon, allowing local users to carry out a denial of service attack on the daemon.

    • Update to 2.5-1
    Published Updated
  5. CVE-2019-9192

    High · CVSS 7.5EPSS 2.45%No fix published

    CVE-2019-9192

    In the GNU C Library (aka glibc or libc6) through 2.29, check_dst_limits_calc_pos_1 in posix/regexec.c has Uncontrolled Recursion, as demonstrated by '(|)(\\1\\1)*' in grep, a different issue than CVE-2018-20796. NOTE: the software maintainer disputes that this is a vulnerability because the behavior occurs only with a crafted pattern

    Published Updated
  6. CVE-2009-5155

    High · CVSS 7.5EPSS 3.91%Fix available

    CVE-2009-5155

    In the GNU C Library (aka glibc or libc6) before 2.28, parse_reg_exp in posix/regcomp.c misparses alternatives, which allows attackers to cause a denial of service (assertion failure and application exit) or trigger an incorrect result by attempting a regular-expression match.

    • Update to 2.28-1
    Published Updated
  7. CVE-2016-10739

    Medium · CVSS 5.3EPSS 0.48%Fix available

    CVE-2016-10739

    In the GNU C Library (aka glibc or libc6) through 2.28, the getaddrinfo function would successfully parse a string that contained an IPv4 address followed by whitespace and arbitrary characters, which could lead applications to incorrectly assume that it had parsed a valid string, without the possibility of embedded HTTP headers or other potentially dangerous substrings.

    • Update to 2.28-6
    Published Updated
  8. CVE-2019-6488

    High · CVSS 7.8EPSS 0.45%Fix available

    CVE-2019-6488

    The string component in the GNU C Library (aka glibc or libc6) through 2.28, when running on the x32 architecture, incorrectly attempts to use a 64-bit register for size_t in assembly codes, which can lead to a segmentation fault or possibly unspecified other impact, as demonstrated by a crash in __memmove_avx_unaligned_erms in sysdeps/x86_64/multiarch/memmove-vec-unaligned-erms.S during a memcpy.

    • Update to 2.28-6
    Published Updated
  9. CVE-2018-11236

    Critical · CVSS 9.8EPSS 7.05%Fix available

    CVE-2018-11236

    stdlib/canonicalize.c in the GNU C Library (aka glibc or libc6) 2.27 and earlier, when processing very long pathname arguments to the realpath function, could encounter an integer overflow on 32-bit architectures, leading to a stack-based buffer overflow and, potentially, arbitrary code execution.

    • Update to 2.27-4
    Published Updated
  10. CVE-2017-18269

    Critical · CVSS 9.8EPSS 4.63%Fix available

    CVE-2017-18269

    An SSE2-optimized memmove implementation for i386 in sysdeps/i386/i686/multiarch/memcpy-sse2-unaligned.S in the GNU C Library (aka glibc or libc6) 2.21 through 2.27 does not correctly perform the overlapping memory check if the source memory range spans the middle of the address space, resulting in corrupt data being produced by the copy operation. This may disclose information to context-dependent attackers, or result in a denial of service, or, possibly, code execution.

    • Update to 2.27-3
    Published Updated
  11. CVE-2018-6551

    Critical · CVSS 9.8EPSS 2.21%Fix available

    CVE-2018-6551

    The malloc implementation in the GNU C Library (aka glibc or libc6), from version 2.24 to 2.26 on powerpc, and only in version 2.26 on i386, did not properly handle malloc calls with arguments close to SIZE_MAX and could return a pointer to a heap region that is smaller than requested, eventually leading to heap corruption.

    • Update to 2.27-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →