p PatchFirst

PatchFirst · Latest vulnerabilities

glibc vulnerabilities · Page 9

Vulnerability published for glibc in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 169

  1. CVE-2002-1146

    Not ratedEPSS 3.28%Fix available

    CVE-2002-1146

    The BIND 4 and BIND 8.2.x stub resolver libraries, and other libraries such as glibc 2.2.5 and earlier, libc, and libresolv, use the maximum buffer size instead of the actual size when processing a DNS response, which causes the stub resolvers to read past the actual boundary ("read buffer overflow"), allowing remote attackers to cause a denial of service (crash).

    • Update to 2.3
    Published Updated
  2. CVE-2002-0391

    Critical · CVSS 9.8EPSS 58.13%Fix available

    CVE-2002-0391

    Integer overflow in xdr_array function in RPC servers for operating systems that use libc, glibc, or other code based on SunRPC including dietlibc, allows remote attackers to execute arbitrary code by passing a large number of arguments to xdr_array through RPC services such as rpc.cmsd and dmispd.

    • Update to 2.2.5-13
    Published Updated
  3. CVE-2003-0028

    Not ratedEPSS 15.03%Fix available

    CVE-2003-0028

    Integer overflow in the xdrmem_getbytes() function, and possibly other functions, of XDR (external data representation) libraries derived from SunRPC, including libnsl, libc, glibc, and dietlibc, allows remote attackers to execute arbitrary code via certain integer values in length fields, a different vulnerability than CVE-2002-0391.

    • Update to 2.3.1-16
    Published Updated
  4. CVE-2002-0684

    Not ratedEPSS 5.86%Fix available

    CVE-2002-0684

    Buffer overflow in DNS resolver functions that perform lookup of network names and addresses, as used in BIND 4.9.8 and ported to glibc 2.2.5 and earlier, allows remote malicious DNS servers to execute arbitrary code through a subroutine used by functions such as getnetbyname and getnetbyaddr.

    • Update to 2.2.5-8
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →