p PatchFirst

PatchFirst · Latest vulnerabilities

openssl vulnerabilities · Page 12

Vulnerabilities published for openssl in the last 30 days: 13. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 289

  1. CVE-2007-6755

    Not ratedEPSS 1.63%Fix available

    CVE-2007-6755

    The NIST SP 800-90A default statement of the Dual Elliptic Curve Deterministic Random Bit Generation (Dual_EC_DRBG) algorithm contains point Q constants with a possible relationship to certain "skeleton key" values, which might allow context-dependent attackers to defeat cryptographic protection mechanisms by leveraging knowledge of those values. NOTE: this is a preliminary CVE for Dual_EC_DRBG; future research may provide additional details about point Q and associated attacks, and could potentially lead to a RECAST or REJECT of this CVE.

    • Update to 1.1.0b-2
    Published Updated
  2. CVE-2013-0169

    Not ratedEPSS 35.58%Fix available

    CVE-2013-0169

    The TLS protocol 1.1 and 1.2 and the DTLS protocol 1.0 and 1.2, as used in OpenSSL, OpenJDK, PolarSSL, and other products, do not properly consider timing side-channel attacks on a MAC check requirement during the processing of malformed CBC padding, which allows remote attackers to conduct distinguishing attacks and plaintext-recovery attacks via statistical analysis of timing data for crafted packets, aka the "Lucky Thirteen" issue.

    • Update to 1.0.1e-1
    Published Updated
  3. CVE-2012-4929

    Not ratedEPSS 4.35%Fix available

    CVE-2012-4929

    The TLS protocol 1.2 and earlier, as used in Mozilla Firefox, Google Chrome, Qt, and other products, can encrypt compressed data without properly obfuscating the length of the unencrypted data, which allows man-in-the-middle attackers to obtain plaintext HTTP headers by observing length differences during a series of guesses in which a string in an HTTP request potentially matches an unknown string in an HTTP header, aka a "CRIME" attack.

    • Update to 1.0.1e-5
    Published Updated
  4. CVE-2011-5095

    Not ratedEPSS 2.06%Fix available

    CVE-2011-5095

    The Diffie-Hellman key-exchange implementation in OpenSSL 0.9.8, when FIPS mode is enabled, does not properly validate a public parameter, which makes it easier for man-in-the-middle attackers to obtain the shared secret key by modifying network traffic, a related issue to CVE-2011-1923.

    • Update to 0.9.8a-1
    Published Updated
  5. CVE-2012-2333

    Not ratedEPSS 27.87%Fix available

    CVE-2012-2333

    Integer underflow in OpenSSL before 0.9.8x, 1.0.0 before 1.0.0j, and 1.0.1 before 1.0.1c, when TLS 1.1, TLS 1.2, or DTLS is used with CBC encryption, allows remote attackers to cause a denial of service (buffer over-read) or possibly have unspecified other impact via a crafted TLS packet that is not properly handled during a certain explicit IV calculation.

    • Update to 1.0.1c-1
    Published Updated
  6. CVE-2012-2110

    Not ratedEPSS 47.91%Public exploitFix available

    CVE-2012-2110

    The asn1_d2i_read_bio function in crypto/asn1/a_d2i_fp.c in OpenSSL before 0.9.8v, 1.0.0 before 1.0.0i, and 1.0.1 before 1.0.1a does not properly interpret integer data, which allows remote attackers to conduct buffer overflow attacks, and cause a denial of service (memory corruption) or possibly have unspecified other impact, via crafted DER data, as demonstrated by an X.509 certificate or an RSA public key.

    • Update to 1.0.1a-1
    Published Updated
  7. CVE-2012-1165

    Not ratedEPSS 6.77%Fix available

    CVE-2012-1165

    The mime_param_cmp function in crypto/asn1/asn_mime.c in OpenSSL before 0.9.8u and 1.x before 1.0.0h allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) via a crafted S/MIME message, a different vulnerability than CVE-2006-7250.

    • Update to 1.0.0h-1
    Published Updated
  8. CVE-2012-0884

    Not ratedEPSS 13.65%Fix available

    CVE-2012-0884

    The implementation of Cryptographic Message Syntax (CMS) and PKCS #7 in OpenSSL before 0.9.8u and 1.x before 1.0.0h does not properly restrict certain oracle behavior, which makes it easier for context-dependent attackers to decrypt data via a Million Message Attack (MMA) adaptive chosen ciphertext attack.

    • Update to 1.0.0h-1
    Published Updated
  9. CVE-2011-4354

    Not ratedEPSS 2.99%Fix available

    CVE-2011-4354

    crypto/bn/bn_nist.c in OpenSSL before 0.9.8h on 32-bit platforms, as used in stunnel and other products, in certain circumstances involving ECDH or ECDHE cipher suites, uses an incorrect modular reduction algorithm in its implementation of the P-256 and P-384 NIST elliptic curves, which allows remote attackers to obtain the private key of a TLS server via multiple handshake attempts.

    • Update to 0.9.8o-4squeeze3
    Published Updated
  10. CVE-2012-0050

    Not ratedEPSS 13.69%Fix available

    CVE-2012-0050

    OpenSSL 0.9.8s and 1.0.0f does not properly support DTLS applications, which allows remote attackers to cause a denial of service (crash) via unspecified vectors related to an out-of-bounds read. NOTE: this vulnerability exists because of an incorrect fix for CVE-2011-4108.

    • Update to 1.0.0g-1
    Published Updated
  11. CVE-2011-4577

    Not ratedEPSS 8.19%Fix available

    CVE-2011-4577

    OpenSSL before 0.9.8s and 1.x before 1.0.0f, when RFC 3779 support is enabled, allows remote attackers to cause a denial of service (assertion failure) via an X.509 certificate containing certificate-extension data associated with (1) IP address blocks or (2) Autonomous System (AS) identifiers.

    • Update to 1.0.0f-1
    Published Updated
  12. CVE-2011-3210

    Not ratedEPSS 4.56%Fix available

    CVE-2011-3210

    The ephemeral ECDH ciphersuite functionality in OpenSSL 0.9.8 through 0.9.8r and 1.0.x before 1.0.0e does not ensure thread safety during processing of handshake messages from clients, which allows remote attackers to cause a denial of service (daemon crash) via out-of-order messages that violate the TLS protocol.

    • Update to 1.0.0e-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →