p PatchFirst

PatchFirst · Latest vulnerabilities

qemu vulnerabilities · Page 11

Vulnerabilities published for qemu in the last 30 days: 7. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 501

  1. CVE-2020-11869

    Low · CVSS 3.3EPSS 0.4%Fix available

    CVE-2020-11869

    An integer overflow was found in QEMU 4.0.1 through 4.2.0 in the way it implemented ATI VGA emulation. This flaw occurs in the ati_2d_blt() routine in hw/display/ati-2d.c while handling MMIO write operations through the ati_mm_write() callback. A malicious guest could abuse this flaw to crash the QEMU process, resulting in a denial of service.

    • Update to 1:5.0-1
    Published Updated
  2. CVE-2020-1711

    High · CVSS 7.7EPSS 4.02%Fix available

    CVE-2020-1711

    An out-of-bounds heap buffer access flaw was found in the way the iSCSI Block driver in QEMU versions 2.12.0 before 4.2.1 handled a response coming from an iSCSI server while checking the status of a Logical Address Block (LBA) in an iscsi_co_block_status() routine. A remote user could use this flaw to crash the QEMU process, resulting in a denial of service or potential execution of arbitrary code with privileges of the QEMU process on the host.

    • Update to 1:4.2-2
    Published Updated
  3. CVE-2014-0148

    Medium · CVSS 5.5EPSS 0.3%Fix available

    CVE-2014-0148

    Qemu before 2.0 block driver for Hyper-V VHDX Images is vulnerable to infinite loops and other potential issues when calculating BAT entries, due to missing bounds checks for block_size and logical_sector_size variables. These are used to derive other fields like 'sectors_per_block' etc. A user able to alter the Qemu disk image could ise this flaw to crash the Qemu instance resulting in DoS.

    • Update to 2.0.0+dfsg-1
    Published Updated
  4. CVE-2014-0147

    Medium · CVSS 6.2EPSS 0.33%Fix available

    CVE-2014-0147

    Qemu before 1.6.2 block diver for the various disk image formats used by Bochs and for the QCOW version 2 format, are vulnerable to a possible crash caused by signed data types or a logic error while creating QCOW2 snapshots, which leads to incorrectly calling update_refcount() routine.

    • Update to 2.0.0+dfsg-1
    Published Updated
  5. CVE-2014-0144

    High · CVSS 8.6EPSS 1.01%Fix available

    CVE-2014-0144

    QEMU before 2.0.0 block drivers for CLOOP, QCOW2 version 2 and various other image formats are vulnerable to potential memory corruptions, integer/buffer overflows or crash caused by missing input validations which could allow a remote user to execute arbitrary code on the host with the privileges of the QEMU process.

    • Update to 2.0.0+dfsg-1
    Published Updated
  6. CVE-2019-20175

    High · CVSS 7.5EPSS 3.36%Fix available

    CVE-2019-20175

    An issue was discovered in ide_dma_cb() in hw/ide/core.c in QEMU 2.4.0 through 4.2.0. The guest system can crash the QEMU process in the host system via a special SCSI_IOCTL_SEND_COMMAND. It hits an assertion that implies that the size of successful DMA transfers there must be a multiple of 512 (the size of a sector). NOTE: a member of the QEMU security team disputes the significance of this issue because a "privileged guest user has many ways to cause similar DoS effect, without triggering this assert.

    • Update to 1:5.0-1
    Published Updated
  7. CVE-2013-2016

    High · CVSS 7.8EPSS 0.51%Fix available

    CVE-2013-2016

    A flaw was found in the way qemu v1.3.0 and later (virtio-rng) validates addresses when guest accesses the config space of a virtio device. If the virtio device has zero/small sized config space, such as virtio-rng, a privileged guest user could use this flaw to access the matching host's qemu address space and thus increase their privileges on the host.

    • Update to 1.5.0+dfsg-1
    Published Updated
  8. CVE-2019-12068

    Low · CVSS 3.8EPSS 0.51%Fix available

    CVE-2019-12068

    In QEMU 1:4.1-1, 1:2.1+dfsg-12+deb8u6, 1:2.8+dfsg-6+deb9u8, 1:3.1+dfsg-8~deb10u1, 1:3.1+dfsg-8+deb10u2, and 1:2.1+dfsg-12+deb8u12 (fixed), when executing script in lsi_execute_script(), the LSI scsi adapter emulator advances 's->dsp' index to read next opcode. This can lead to an infinite loop if the next opcode is empty. Move the existing loop exit after 10k iterations so that it covers no-op opcodes as well.

    • Update to 1:4.1-2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →