p PatchFirst

PatchFirst · Latest vulnerabilities

wireshark vulnerabilities · Page 33

Vulnerabilities published for wireshark in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 756

  1. CVE-2011-1959

    Not ratedEPSS 3.05%Fix available

    CVE-2011-1959

    The snoop_read function in wiretap/snoop.c in Wireshark 1.2.x before 1.2.17 and 1.4.x before 1.4.7 does not properly handle certain virtualizable buffers, which allows remote attackers to cause a denial of service (application crash) via a large length value in a snoop file that triggers a stack-based buffer over-read.

    • Update to 1.6.0-1
    Published Updated
  2. CVE-2011-1140

    Not ratedEPSS 13.06%Public exploitFix available

    CVE-2011-1140

    Multiple stack consumption vulnerabilities in the dissect_ms_compressed_string and dissect_mscldap_string functions in Wireshark 1.0.x, 1.2.0 through 1.2.14, and 1.4.0 through 1.4.3 allow remote attackers to cause a denial of service (infinite recursion) via a crafted (1) SMB or (2) Connection-less LDAP (CLDAP) packet.

    • Update to 1.4.4-1
    Published Updated
  3. CVE-2011-0538

    Not ratedEPSS 7.51%Public exploitFix available

    CVE-2011-0538

    Wireshark 1.2.0 through 1.2.14, 1.4.0 through 1.4.3, and 1.5.0 frees an uninitialized pointer during processing of a .pcap file in the pcap-ng format, which allows remote attackers to cause a denial of service (memory corruption) or possibly have unspecified other impact via a malformed file.

    • Update to 1.4.3-3
    Published Updated
  4. CVE-2010-4538

    Not ratedEPSS 28.98%Public exploitFix available

    CVE-2010-4538

    Buffer overflow in the sect_enttec_dmx_da function in epan/dissectors/packet-enttec.c in Wireshark 1.4.2 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted ENTTEC DMX packet with Run Length Encoding (RLE) compression.

    • Update to 1.2.11-6
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →