p PatchFirst

PatchFirst · Latest vulnerabilities

wolfssl vulnerabilities · Page 8

Vulnerability published for wolfssl in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 150

  1. CVE-2017-2800

    High · CVSS 8.1EPSS 8.53%Public exploitFix available

    CVE-2017-2800

    A specially crafted x509 certificate can cause a single out of bounds byte overwrite in wolfSSL through 3.10.2 resulting in potential certificate validation vulnerabilities, denial of service and possible remote code execution. In order to trigger this vulnerability, the attacker needs to supply a malicious x509 certificate to either a server or a client application using this library.

    • Update to 3.12.0+dfsg-1
    Published Updated
  2. CVE-2015-7744

    Medium · CVSS 5.9EPSS 5.07%Fix available

    CVE-2015-7744

    wolfSSL (formerly CyaSSL) before 3.6.8 does not properly handle faults associated with the Chinese Remainder Theorem (CRT) process when allowing ephemeral key exchange without low memory optimizations on a server, which makes it easier for remote attackers to obtain private RSA keys by capturing TLS handshakes, aka a Lenstra attack.

    • Update to 3.9.10+dfsg-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →