p PatchFirst

PatchFirst · Latest vulnerabilities

@anthropic-ai/claude-code vulnerabilities · Page 2

Vulnerabilities published for @anthropic-ai/claude-code in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 29

  1. CVE-2025-59536

    High · CVSS 8.7EPSS 27.24%Fix available

    Claude Code's startup trust dialog could lead to Command Execution attack

    Claude Code is an agentic coding tool. Versions before 1.0.111 were vulnerable to Code Injection due to a bug in the startup trust dialog implementation. Claude Code could be tricked to execute code contained in a project before the user accepted the startup trust dialog. Exploiting this requires a user to start Claude Code in an untrusted directory. Users on standard Claude Code auto-update will have received this fix automatically. Users performing manual updates are advised to update to the latest version. This issue is fixed in version 1.0.111.

    • Update to 1.0.111
    Published Updated
  2. CVE-2025-59828

    High · CVSS 7.7EPSS 0.36%Fix available

    Claude Code Vulnerable to Arbitrary Code Execution via Plugin Autoloading with Specific Yarn Versions

    Claude Code is an agentic coding tool. Prior to Claude Code version 1.0.39, when using Claude Code with Yarn versions 2.0+, Yarn plugins are auto-executed when running yarn --version. This could lead to a bypass of the directory trust dialog in Claude Code, as plugins would be executed prior to the user accepting the risks of working in an untrusted directory. Users running Yarn Classic were unaffected by this issue. This issue has been fixed in version 1.0.39. Users on standard Claude Code auto-update will have received this fix automatically. Users performing manual updates are advised to update to the latest version.

    • Update to 1.0.39
    Published Updated
  3. CVE-2025-59041

    High · CVSS 8.7EPSS 0.55%Fix available

    Claude Code vulnerable to arbitrary code execution caused by maliciously configured git email

    Claude Code is an agentic coding tool. At startup, Claude Code executed a command templated in with `git config user.email`. Prior to version 1.0.105, a maliciously configured user email in git could be used to trigger arbitrary code execution before a user accepted the workspace trust dialog. Users on standard Claude Code auto-update will have received this fix automatically. Users performing manual updates are advised to update to version 1.0.105 or the latest version.

    • Update to 1.0.105
    Published Updated
  4. CVE-2025-58764

    High · CVSS 8.7EPSS 0.55%Fix available

    Claude Code rg command had Command Injection that allowed bypass of user approval prompt for command execution

    Claude Code is an agentic coding tool. Due to an error in command parsing, versions prior to 1.0.105 were vulnerable to a bypass of the Claude Code confirmation prompt to trigger execution of an untrusted command. Reliably exploiting this requires the ability to add untrusted content into a Claude Code context window. Users on standard Claude Code auto-update will have received this fix automatically. Users performing manual updates are advised to update to version 1.0.105 or the latest version.

    • Update to 1.0.105
    Published Updated
  5. GHSA-ph6w-f82w-28w6

    High · CVSS 8.7Fix available

    Claude Code Vulnerable to Arbitrary Code Execution Due to Insufficient Startup Warning

    When Claude Code was started in a new directory, it displayed a warning asking, "Do you trust the files in this folder?". This warning did not properly document that selecting "Yes, proceed" would allow Claude Code to execute files in the folder without additional confirmation. This may not have been clear to a user so we have updated the warning to clarify this functionality.  Users on standard Claude Code auto-update will have received this fix automatically. Users performing manual updates are advised to update to the latest version. Thank you to https://hackerone.com/avivdon for reporting this issue!

    • Update to 1.0.87
    Published Updated
  6. CVE-2025-55284

    High · CVSS 7.1EPSS 0.6%Fix available

    Claude Code's Permissive Default Allowlist Enables Unauthorized File Read and Network Exfiltration in Claude Code

    Claude Code is an agentic coding tool. Prior to version 1.0.4, it's possible to bypass the Claude Code confirmation prompts to read a file and then send file contents over the network without user confirmation due to an overly broad allowlist of safe commands. Reliably exploiting this requires the ability to add untrusted content into a Claude Code context window. Users on standard Claude Code auto-update received this fix automatically after release. Current users of Claude Code are unaffected, as versions prior to 1.0.24 are deprecated and have been forced to update.

    • Update to 1.0.4
    Published Updated
  7. CVE-2025-54794

    High · CVSS 7.7EPSS 1.39%Fix available

    Claude Code Research Preview has a Path Restriction Bypass which could allow unauthorized file access

    Claude Code is an agentic coding tool. In versions below 0.2.111, a path validation flaw using prefix matching instead of canonical path comparison, makes it possible to bypass directory restrictions and access files outside the CWD. Successful exploitation depends on the presence of (or ability to create) a directory with the same prefix as the CWD and the ability to add untrusted content into a Claude Code context window. This is fixed in version 0.2.111.

    • Update to 0.2.111
    Published Updated
  8. CVE-2025-54795

    High · CVSS 8.7EPSS 1.04%Fix available

    Claude Code echo command allowed bypass of user approval prompt for command execution

    Claude Code is an agentic coding tool. In versions below 1.0.20, an error in command parsing makes it possible to bypass the Claude Code confirmation prompt to trigger execution of an untrusted command. Reliably exploiting this requires the ability to add untrusted content into a Claude Code context window. This is fixed in version 1.0.20.

    • Update to 1.0.20
    Published Updated
  9. CVE-2025-52882

    High · CVSS 8.8EPSS 0.36%Fix available

    Claude Code IDE extensions allow websocket connections from arbitrary origins

    Claude Code is an agentic coding tool. Claude Code extensions in VSCode and forks (e.g., Cursor, Windsurf, and VSCodium) and JetBrains IDEs (e.g., IntelliJ, Pycharm, and Android Studio) are vulnerable to unauthorized websocket connections from an attacker when visiting attacker-controlled webpages. Claude Code for VSCode IDE extensions versions 0.2.116 through 1.0.23 are vulnerable. For Jetbrains IDE plugins, Claude Code [beta] versions 0.1.1 through 0.1.8 are vulnerable. In VSCode (and forks), exploitation would allow an attacker to read arbitrary files, see the list of files open in the IDE, get selection and diagnostics events from the IDE

    • Update to 1.0.24
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →