p PatchFirst

PatchFirst · Latest vulnerabilities

pocketmine/pocketmine-mp 5.43.1: known vulnerabilities

Known vulnerability affecting pocketmine/pocketmine-mp 5.43.1: 1. Compare the fixes below with your installed release.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. CVE-2026-86198

    Low · CVSS 2.3EPSS 0.38%Fix available

    PocketMine-MP before 5.44.2 Denial of Service via ResourcePackClientResponsePacket

    PocketMine-MP versions before 5.44.2 fail to properly validate multiple ResourcePackClientResponsePacket packets with STATUS_COMPLETED status during resource pack handling. Malicious clients can send batches of these packets to repeatedly trigger pre-spawn progression, creating duplicate Player objects and amplifying memory consumption and network traffic.

    • Update to 5.44.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →